2011 LT Clip + LT Switch EXT v2.1 Kit

cypheredout

Noob Account
Mar 9, 2011
9
0
Alright I think its fair for me to ask now searching forums for a couple hours.

XBOX 360 Arcade
LiteON 8385v1
Going from ix LT to LT+ (should say went)

I have the 2011 LT Clip + LT Switch EXT v2.1 Kit. Installed the LT Clip is green all is good there. I had to change the dip switch on the LT Switch EXT so it was for the 20 setting cause I couldn't flash otherwise. I successfully flashed and all is well. So i recapped all the instructions and noticed one thing on the LT Switch v2 instructions (the only instructions i found on the v2 switches) it said the normal light is supposed to be green. mine is red all the time( note i have the 2.1 ext switch). I am wondering if the 2.1 ext switch was made different? It flashed... it ejects... is it safe having the red light? fyi i stuck it in a spare xbox its still red..didnt let it boot all the way just enought to get power and check.

thanks
 

cypheredout

Noob Account
Mar 9, 2011
9
0
I had a good reason to be worried. I put it in the xbox and its not reading discs. Xbox boots up fine no errors and i should says its not recognizing discs. put on in it spins up and just says open tray on dashboard like theres not disc. Opened it back up and hooked up to ck3 pro again and double checked all connections. All is good laser fires but no luck. Any ideas?

I did notice today that the lt ext was getting warm.
 

marshamods

VIP Member
Mar 7, 2010
1,905
0
ohio
does the drive respond normally? Eject spin up etc. Make sure the clip is not shorting out anything if it is not responding normally.