LITEON DG-16D2S A0A2 extraction failure

Mr. Chunky

Noob Account
Dec 23, 2011
4
0
Running into a wall here and need some forum expertise!

I purchased a "new" DG-16D2S-09C (A0A2) drive, FW 74850C, and want to flash it. I'm using x360usb pro and ck3i (have extracted with this hardware before) and Probe III. The problem I'm having is the same that many other have had - Phatkey extraction failed.

I've searched/read until my eyes bleed and I've reached a dead end. I've been over the guide(S) many times, tried numerous timings with mpx01 and button presses, multiple computers, drive tray in several positions, and still no success. I've probably tried to extract a few hundred times, not exaggerating.

The only thing I find a little unusual is that JF reports the firmware to be "9345". I have no history on this drive, other than it should be 100% working as original/new. Could this have anything to do with extraction failure? Also, there is no pause after pressing 'OK' in the "Extract complete" window (yes, 5-second power cycle), just an immediate "Phatkey extraction failed!" every time.

Either I'm completely overlooking something here, or key cannot be extracted using this method on this drive. Whatever the case, I would be seriously happy to find a way to flash this drive! Thanks!!


Here's my log - same exact output every time:

ungleFlasher 0.1.90 Beta (293)
Session Started

This is a Wow 64 process running on 8 x 64 bit CPUs
X360USB PRO detected, Version 0.18

portio64.sys Driver Installed
portio64.sys Driver Started, thanks Schtrom !
Found 7 I/O Ports.
Found 0 Com Ports.
Found 7 windows drives
Found 3 CD/DVD drives

PortIO unloaded.
Drive is Lite-On..
Drive is Lite-On..
Sending Vendor Intro to port 0x0000
Status 0x51
Re-sending Vendor Intro:
...............................
Serial flash found with Status 0x52

Extracted drive key failed Verification !


PhatKey extraction failed!
 

Fisticuffs

VIP Member
Mar 14, 2011
1,326
0
Arizona, US
lol nice catch krypt1c, He is right, New drives don't have keys on them, and liteon's 74, 83, and 93 are all the same hardware, When you get a new one usually their 93's, Load your fw from previous drive as source and as target then click liteon erase
 

Mr. Chunky

Noob Account
Dec 23, 2011
4
0
OK then, I am obviously missing something here... I was under the impression that all drives (new and ones installed) had keys. Wrong assumption on my part and thanks for the correction.

This leaves me in an interesting situation. I did not purchase the drive to replace an existing one, and therefore have no "original" keys. I was planning to install 0800 v3, so does this mean I don't actually need a key (I can just flash as-is)?

Many thanks for the info!