Black Screen after Splash Screen

theyoman94

Noob Account
Apr 27, 2020
4
1
USA
Hey all, Im on SXOS 2.9.5 Beta, and im on firmware 9.1.0. no themes, i remember that being an issue in the past. EXFAT formatted SD Card.

So i have had issues with my switch for a few months where it would tell me the sd card had been removed, even though i didnt touch it or anything. So, i replaced the Reader, and Now when i boot the switch i get nothing besides a Black Screen after the SXOS logo. (which to me says its reading the SD card, otherwise it would give me this missing Boot.dat file) (I can still hit + to get to the menu. )

I've tried replacing all the important files, as well as other SD cards ect. Like i mentioned, It boots the SXOS Fw splash, i can access the SX menu from there, but if i do anything else, all i get is a black screen once i finish that inital SXOS splash.

Should i try and wipe the SD Card? any ideas i could get from you guys? Im about to go buy a LITE at target. XD
 

Velvet

Senior Member
Nov 9, 2018
233
18
Yes, it is always recommended to delete everything from the card and start clean. I'm curious to know why and how did you replace the reader. Do you mean the SD card reader?
 

theyoman94

Noob Account
Apr 27, 2020
4
1
USA
Yes, it is always recommended to delete everything from the card and start clean. I'm curious to know why and how did you replace the reader. Do you mean the SD card reader?
Yeah, i replaced the SD card reader. It kept stop reading while playing games and stuff and force shutdown.
 

Velvet

Senior Member
Nov 9, 2018
233
18
Yeah, i replaced the SD card reader. It kept stop reading while playing games and stuff and force shutdown.
That may be the cause of the problem. I haven't had any experience replacing Switch hardware before. Maybe one of the members with experience with Switch hardware may come to assist you.
 

theyoman94

Noob Account
Apr 27, 2020
4
1
USA
That may be the cause of the problem. I haven't had any experience replacing Switch hardware before. Maybe one of the members with experience with Switch hardware may come to assist you.
See, i dont know if its that, mostly cause it clearly reads the boot.dat file. It was a pretty straightforward install, and you dont have to get into any of the main hardware or anything.
 

Velvet

Senior Member
Nov 9, 2018
233
18
See, i dont know if its that, mostly cause it clearly reads the boot.dat file. It was a pretty straightforward install, and you dont have to get into any of the main hardware or anything.
Ok, delete everything on your SD card and make sure you start with nothing but only the needed files (license and boot file). Make sure you use the latest beta SX OS.
 

slamride

Senior Member
Nov 28, 2018
230
28
Having a previous card reader error I would check your install of the new sd card reader. It may not be seated properly. I have had this issue after repairs. The pins can be easily bent on the plug. Also putting the foam on top of the connector will help keep it seated when you install back cover. Sometimes they are loose and it helps to tighten it. Try pressing on case where reader plug is and see if it helps.