Error on 9.2.0/SX OS 2.9.4 - title requires higher system firmware

switchfan

Noob Account
Nov 1, 2019
1
1
UK
I'm trying to install an NSP update to Two Point Hospital in SX Installer 3.02 but when I try to do so, I get the error 'Title requires higher system firmware'. I'm running Switch firmware 9.2.0 and SX OS 2.9.4. The 'Ignore Software Firmware Check' option is already enabled. Any ideas on a fix or workaround? Thanks.
 

copyandpaste

Junior Member
Sep 21, 2019
18
1
usa
Yeah it seems like SX Installer 3.02 has a few odd bugs. going back to SX Installer 3.01 remedies these, however i think that v3.01 isn't able to even read anything that requires 9.1.0 or above.

As mentioned tinfoil and/or goldleaf will do what you need. however sx os' default installer (not the SX Installer app) will also work. as a bonus it can also read an external drive like SX Installer can, so you're not missing any function that way.
 

Falki14

Junior Member
Aug 16, 2018
14
3
Yes use the newest Tinfoil R27. That works on me very good. T think too the SX Installer is to old for 9.2.0.
 

Chamalo

Junior Member
Aug 6, 2018
20
3
Same here, since 9.0 sx installer got this bug.
Impossible to install any update or dlc without this error.
have some bug on name/image of some games (syntax error, no name, wrong image) spotted too