Fried something trying to achieve RGH2 on Falcon?!

dakku

Noob Account
Jul 10, 2014
4
0
Hi.

A week ago i bought a XBox 360(Falcon v1, Dash 2.0.16756, CB5774) and read a few days about whats going on and how to modify those. My previous experience was the original XBox with TSOP flash which was pretty easy compared to
the current RGH.
However i gave it a try and now im scared that i killed the box. Let me describe what i did:
1. Build a LPT-JTag cable to dump the nand (i made the one described here: http://www.se7ensins.com/forums/threads/jtag-rgh-r-jtag-xbox-360-ultimate-exploit-guide.804054/)
2. dumped the nand with nandpro 8 times to be sure nothing goes wrong
3. created ecc image with J-Runner and flashed it with nandpro.
4. Installed Coolrunner rev c and wired it to the board (typical, non-shielded cpu_rst cable).
5. Flashed cr with rgh2.0 image from 360gcProg (using selfmade lpt cable)
5. After it didnt want to boot into xell i tried to play with a small trimmer and a cap which worked out and booted into xell (trimmer on ~2kohm and 470pF).
6. Used j-runner to get stuff like cpu key and fuses over LAN(still didn't figure out what these are for)
7. created freeboot rgh 2.0 image in xebuild gui 2.093 (loaded my nand dump as source, added cpu key and pressed generate hacked image)
8. used nand to flash the generated image to xbox

So far everything was nice. After point 8 however the frontplace of the xbox didn't blink anymore but was lightning constantly and the cr was trying to glitch... no success. After some research i figured out that constant lightning is not a
problem and seems to occure in many cases.
What was strange as well was that after glitching a few minutes i would sometimes get stuck. cr's green led wasnt blinking anymore and the fan was restarting like 3 times a second. Freeze?!

I thought i give it another try to write the hacked image on the box again.... didn't work. Then again i rechecked my soldering points and couldn't find any problems. To remove one potential error source i removed my soldered lpt cables.
And this is where i was shocked because i couldn't even start the xbox. The frontplate didn't show any green light. Just the cr was lightning red. The box also cannot be turned on by the eject button.

Desperately i tried to check if i still was able to read or write the nand. Reading and writing failed but erasing worked... The strange thing is nandpro was able to erase the blocks 0 to 1FF but 200 to 3FF failed.
Are some pins of the nand desoldered or why can he erase the half but not the second?
However reading or writing doesn't work at all.

Now im asking myself if i killed the box or if there are chances to revive it :(

I gonna attach some pics of the mobo, maybe someone will be able to find something. No matter what i really appreciate you guys for all the hard work you do to find those glitches and other possibilities to hack the box.

Thanks a lot guys.
 

Attachments

Last edited:

dakku

Noob Account
Jul 10, 2014
4
0
Thanks for the fast reply Krafter. I took a look but couldn't find any loose paths or solders points:
IMAG4305.jpgIMAG4306.jpgIMAG4308.jpgIMAG4309.jpgIMAG4310.jpg
 

Krafter

VIP Member
Apr 17, 2011
3,737
118
Indiana
You might want to ditch the LTP cable and buy a USB NAND flasher and flash back the stock image. Other than that I'm not sure what to suggest other than check the board really good for any damage.

What color is the light on the PSU?
 

dakku

Noob Account
Jul 10, 2014
4
0
The PSU is always orange so i suppose not bypass. I also cannot see any damage on the board. I just dunno if a usb flasher would be better. I mean lpt worked like a charm before and now its complaining to read or write. Is it actually possible that the nand is corrupted with bad blocks or something where part of it cannot be written on it?
 

Krafter

VIP Member
Apr 17, 2011
3,737
118
Indiana
There's a difference between bad blocks and a corruption. Yes it is possible that a corrupt NAND could cause this. A LPT cable and USB use a very different method of writing so its possible that it will write when the lot won't. Besides LPT isn't supported here.

NAND corruptions and bad reads are exactly why LPT isn't supported.
 
Last edited:

mat1110

Senior Member
Jun 21, 2012
135
0
UK
Hard to tell on picture on my phone but they look like square edges on the coolrunner. Can you post a picture of your coolrunner as I don't see any full pictures of yours.