How to Update NAND-X Using A CK3i / CK3 Pro

liamg1285

Noob Account
Sep 24, 2011
78
0
just updated my nandx with the usb cable and went perfectly and flashed the coolrunner ready for the install at the weekend
 

neural

Noob Account
Oct 29, 2009
52
0
leigh
just for reference if your computer doesnt have com ports on your motherboard windows doesnt load device drivers com port services

tried my ck3 on an old laptop installed drivers first time tried on 5 different laptops and pcs with different windows versions (98, xp, vista and win 7) that didnt have com ports and it didnt work even assigned a virtual com port to a usb socket and that doesnt work either.
 

sailsy

VIP Member
Jul 7, 2011
188
0
Chester
Disaster eventually got my nand x update cable!

Followed the guide!

First problem had to solder wire on ck3 was really worried but did it i was well happy with myself tidy job getting better i thought!

Hard bit over next the easy bit or so i thought!

Anyway kept getting the autobaud error so typically thought it was my soldering gave the wire a good tug to check and guess what solder was very good pulled the wire out of the chip brilliant.

So does that mean my ck3 is no good anymore?

Also checking my order from months ago it actually say's i have a ck3i how do i know for sure? in device manager it comes up xecuter ck3 pro!



Thanks Sailsy.
 

afsilver

VIP Member
May 23, 2010
537
0
Haugesund, Norway
www.google.com
Disaster eventually got my nand x update cable!

Followed the guide!

First problem had to solder wire on ck3 was really worried but did it i was well happy with myself tidy job getting better i thought!

Hard bit over next the easy bit or so i thought!

Anyway kept getting the autobaud error so typically thought it was my soldering gave the wire a good tug to check and guess what solder was very good pulled the wire out of the chip brilliant.

So does that mean my ck3 is no good anymore?

Also checking my order from months ago it actually say's i have a ck3i how do i know for sure? in device manager it comes up xecuter ck3 pro!

Link To Image

Thanks Sailsy.
without that pin you can't update your nand-x, but it will power your drive just fine..

but your update cable has only 3 wires? mine has 5 (selfmade)
edit: just looked at my cable and i guess the two cables you are missing is just hiding (my bad)
 

page360

VIP Member
Apr 9, 2011
361
0
Portugal
I just follow this tutorial and now my Nand-X does not work (even tested on old Jtag I had and tried to dump to make sure it was not bad solder points )

"Looking for usb interface device
Can not continue" everytime
 

hodgie

VIP Member
Apr 8, 2011
428
0
Southern, VT (usa)
Disaster eventually got my nand x update cable!

Followed the guide!

First problem had to solder wire on ck3 was really worried but did it i was well happy with myself tidy job getting better i thought!

Hard bit over next the easy bit or so i thought!

Anyway kept getting the autobaud error so typically thought it was my soldering gave the wire a good tug to check and guess what solder was very good pulled the wire out of the chip brilliant.

So does that mean my ck3 is no good anymore?

Also checking my order from months ago it actually say's i have a ck3i how do i know for sure? in device manager it comes up xecuter ck3 pro!

Link To Image

Thanks Sailsy.
Just out of curiousity, did you try with your switch on USB instead of COM?
 

sailsy

VIP Member
Jul 7, 2011
188
0
Chester
Yeah noticed that in picture! Yeah I tried all ways! just wish I wasn't so quick to blame my soldering! Should if read further along posts!
Anyone want to update my nand x for me?
 

TOMMYX2

Noob Account
Dec 12, 2011
2
0
i get by Nand-X and i have installed my 'Usb driver on win7 64 Bit.I see Prüftechnik XECUTER NAND-X USB
in my Device Manger but no Com Port:confused:I have no Ck3 only the Usb Update Kabel

i have try the new nand-x_usb_driver but im cant install it,need some help
thx
 

klepoh

Noob Account
Jan 21, 2011
43
0
Jakarta
just updated my nand-x,works great now, i can program coolrunner via nand-x :D,,, thx uber .... :D
always easy tuts :D

sorry bad english :D
 

Toman

Noob Account
Dec 17, 2010
35
0
EU/Kuneshau
i have problem..... error: Failed to autobaud - step1.

have:
- CK3 rev. D - with wire fix, windows driver OK, corect Com port (12)
- original Ck3i to nand-x cable
- light on NandX is red

i tried:
- 2x PC 1xnotebok
- oscilator 12/14.745
- all baud speed
- off/on, then start

any ideas?

thanks

//my CK3:


 
Last edited:

Support Our Sponsors