Impossible to launch a game that runs on a cartdridge when using the custom firmware

druid

Junior Member
Dec 25, 2019
21
1
DTC
Hello,

When I boot on the custom firmware I can play on games installed from an xci, but i cannot play on games that I have installed from a cartridge, and that need a cartridge to run. Is it expected?

Thanks
 

imprezgc8

Bannnnnn-Kai!
Staff member
Troll Eating Dogs
Nov 26, 2007
2,379
138
The Cloud
I am not sure I 100% understand. You cannot put a cartridge in the slot and play the game when booted to CFW?

What version of SX are you using?
What FW are you using?
Are you using emunand?
 
  • Like
Reactions: druid

druid

Junior Member
Dec 25, 2019
21
1
DTC
I'm running 2.9.3. Nintendo firmware is 9.1. I am using emmunand, it is stored on the sd filesystem.

As an example:
- I boot on sxos and select the cfw
- I have a cartridge of Lego Harry Potter. I put it in the dedicated slot.
- When I click on the game it states I cannot play it because it has to download stuff from the internet (my wife is currently playing it so I can't share the exact errorcode, will do later)

To be able to play this game I then have to stop the console then restart it using the regular firmware (no jig usage etc). And when I do, it doesn't tell me i need to download anything.

For the record, I havn't set 90dns or anything. So when I'm using the regular firmware it can connect to nintendo servers if it needs to, and that might make the difference for this game i guess...

Yesterday evening I found out one thing though: I do not experience this behavior with Zelda breath of the wild (which has a 1.1 version, not sure if it's related but that means it has files on the drive already i guess).

All this now leads me to think that it's related to the stealth mode, and not to the usage or not of a cartridge.

Thanks
 

medi01

Noob Account
Jul 25, 2018
7
3
I also have a problem of a cartridge game not working.

2.9.3 beta, sysnand 9.1.0

I've updated FW from 7.0.1 using offline "no fuses" method.
 
  • Like
Reactions: druid

druid

Junior Member
Dec 25, 2019
21
1
DTC
So i just made the test:
- i start sx os to the cfw, with emunand enabled (emunand has partitioned the sd, but i did the same test before with the emunand files set onto the sd card)
- i insert the cartridge for Lego Harry Potter (it's already installed and played before i even tried to install sx os on the console)
- i click on the game tile
- it pops out a message telling me some files can't be found and need to be downloaded. It asks if I want to start it anyways or to download the files.
- I click to start it as is (without downloading files), but then it pops out another popup stating data has to be downloaded and i can only click on "Cancel" or "Download".
Obviously i won't click on download, especially because I'm set to use stealth mode.

Now, if I shutdown the console, then start it on the regular fw, i am able to start that same game without having to download anything.
 

Tigu25

Full Member
Sep 26, 2018
36
8
1.1.1.1
have you checked which version of the game is loading? Maybe the one on emunand is not updated, and the one on OFW has been updated.
 

druid

Junior Member
Dec 25, 2019
21
1
DTC
Thanks.

The game was installed before I actually created the emunand, so I suspect it would be in the same state, no? Anyways, it's version 1.0 on both.

Also, yesterday i noticed that the mario kart 8 deluxe i have installed on the ofw doesn't appear when i boot the cfw. From what you're telling me above, i supposed it's expected, as it was installed from the official eshop after i had built the emunand, right?