Ni No Kuni crashes SX OS 2.9.5 Beta [Error Code 2162-0002]

TavaresX3

Noob Account
Dec 14, 2018
6
3
Hi guys,

Before the 10.0.1 OFW release, I was playing Ni No Kuni (NSP installed) on my SX OS 2.9.4 Beta (Emunand) without any problems. I waited for the SX OS 2.9.5 release to update both my OFW and CFW.
So, I updated SX OS to 2.9.5 Beta, updated my Emunand to 10.0.1 through ChoirDuJourNX and then updated my OFW to 10.0.1 to keep playing my online games. After updating, on my Emunand, all of my games run perfectly fine (Resident Evil, Northguard, Darksider 2, Naruto Ultimate Ninja Storm 4, Risk Of Rain 2, etc) - all of these downloaded through h*****p or NSPs from websites - except Ni No Kuni.

When I launch the game I can get all the way to the main menu, select Continue Game and select my save file. That's when it crashes and SX OS identifies the 2162-0002 error. After it happened 2 times, I decided to reinstall the game from another source, still an NSP, and the exact same thing happened. I then tried deleting my old save file from the Switch and starting a new game, but as soon as I accept the User Agreements, SX OS crashes again.
So now, I tried deleting the game again and runing an XCI version of it, but it crashed SX OS again.

I'd really appreciate some help getting this game to run so I can finish it for good and focus on Ni No Kuni 2. This is the only game that crashes my Switch, either NSP or XCI, either runing from an HDD or my SD Card.

My Current Setup: SYSNAND on 10.0.1, Emunand on 10.0.1 with SX OS 2.9.5 Beta - EXFat Format SD CARD (yeah, I know, should be FAT32, but I did the whole Emunand creation as soon as SX OS had it available and haven't gotten around to re-do the whole process to reformat my SD Card to FAT32)
I'm trying to run the Europe release of Ni No Kuni.

Note: I do have SX Autoloader, but I already updated it. I do not have any custom themes installed.
 

alanzuti

Noob Account
Apr 30, 2020
1
1
Argentina
Hi, I have the same issue with sysnand 10.0.0. It looks like be a problem with the checkpoint saves. If i delete a game and reinstall it from my own dump, still crash. But if i download it again from another source (torrent for example) it work fine. But when i try to restore my saves get back crash with sxos error code: 2162-0002

The only difference with my dumps and the new one from torrent is that i made saves before the dump with checkpoint. In all cases i talkin about nsp files.

Sysnand 10.0.0 / SX OS 2.9.5 / Chekpoint 3.7.4
 

Samus

Noob Account
May 20, 2020
1
1
G
Tengo el mismo Error con Assassin's Credd III y puede ser que también lo haya con otros juegos, no es justo que SXOS nos haga esto para eso pagamos su servicio! Podrían ayudar para solucionarlo por favor!
 

jmugwump

Junior Member
Jul 30, 2018
14
3
FYI, I got the same error with Ni No Kuni on SX 3.0.2Beta + fw10.0.4.
It crashes anytime I try to load the save file. To get around this I had to use Atmosphere.

For anyone who doesn't fully understand Atmosphere (like me), here's a brief rundown.
On the same SD card you have your SX stuff, you just drop in the Atmosphere files + fusee-primary.bin into the root of the SD (download from GitHub https://github.com/Atmosphere-NX/Atmosphere/releases). Download and Unzip this file "atmosphere-0.13.0-master-32951329+hbl-2.3.3+hbmenu-3.3.0.zip". Copy, paste everything in the file into your root. There should be a few items in there.

Next, you need goldleaf homebrew app to install nsp games, as Atmosphere can only use nsp. Download the Goldleaf nro file from github (https://github.com/XorTroll/Goldleaf/releases). It is just one nro file. Drop it into the switch folder in your root where all your Homebrew nro's usually go.

Next you need "sig patches" that are compatible with 10.0.4 or whatever the latest vers you're on. Just google "sig patches latest" and someone usually has it on a forum (For ex: https://gbatemp.net/threads/sigpatches-for-atmosphere-0-13-0.567542/). It's just an atmosphere folder. Drag and drop contents into the atmosphere folder that you placed in your SD card earlier, and it will auto combine/update.

Lastly, you need a way to inject the atmosphere fw. I have the RCMloader dongle, which you just press the little button to change from injecting SX to Atmos. Stick the dongle in the same way you do with SX OS.
Once you're in Atmoshpere, open homebrew and then the goldleaf app. Select 'Explore the SD card' and look for the nsp game you want to install. Select it and "install". Done. If you get an error stopping you from installing, you prob didn't do the sigpatches thing right.
 
Last edited: