Ni No Kuni crashing SX OS after 2.9.5 Beta Update

TavaresX3

Noob Account
Dec 14, 2018
6
3
Hi guys,

Before the 10.0.1 OFW release, I was playing Ni No Kuni (NSP installed) on my SX OS 2.9.4 Beta (Emunand) without any problems. I waited for the SX OS 2.9.5 release to update both my OFW and CFW.
So, I updated SX OS to 2.9.5 Beta, updated my Emunand to 10.0.1 through ChoirDuJourNX and then updated my OFW to 10.0.1 to keep playing my online games. After updating, on my Emunand, all of my games run perfectly fine (Resident Evil, Northguard, Darksider 2, Naruto Ultimate Ninja Storm 4, Risk Of Rain 2, etc) - all of these downloaded through h*****p or NSPs from websites - except Ni No Kuni.

When I launch the game I can get all the way to the main menu, select Continue Game and select my save file. That's when it crashes and SX OS identifies the 2162-0002 error. After it happened 2 times, I decided to reinstall the game from another source, still an NSP, and the exact same thing happened. I then tried deleting my old save file from the Switch and starting a new game, but as soon as I accept the User Agreements, SX OS crashes again.
So now, I tried deleting the game again and runing an XCI version of it, but it crashed SX OS again.

I'd really appreciate some help getting this game to run so I can finish it for good and focus on Ni No Kuni 2. This is the only game that crashes my Switch, either NSP or XCI, either runing from an HDD or my SD Card.

My Current Setup: SYSNAND on 10.0.1, Emunand on 10.0.1 with SX OS 2.9.5 Beta - EXFat Format SD CARD (yeah, I know, should be FAT32, but I did the whole Emunand creation as soon as SX OS had it available and haven't gotten around to re-do the whole process to reformat my SD Card to FAT32)
I'm trying to run the Europe release of Ni No Kuni.
 
  • Like
Reactions: geminivi

Clock

Junior Member
Dec 29, 2018
10
3
Same problem...it happen as using nsp and xci+update of the game

Sxos 2.9.5 beta.
Firmware sysnand 9.2
 
Last edited:

elanorh295

Full Member
Jan 4, 2019
70
8
US
Same problem...it happen as using nsp and xci+update of the game

Sxos 2.9.5 beta.
Firmware sysnand 9.2
Get 2.9.4 for now. It supports FW 9.2 and is perfectly stable for me.

 
  • Like
Reactions: Clock

Clock

Junior Member
Dec 29, 2018
10
3
Yes i know that previous version works well, i use retroreloaded, thats a launcher and let me choose between the 3 latest versions of sxos to launch..
I answer on the post to let know that 2.9.5 have a bug on that, hope it soon will be arranged..
 

Clock

Junior Member
Dec 29, 2018
10
3
So i have to downgrade from 10.0.1 to 9.2?
for this game is better downgrade to 8.1 o 8.2 and select sxos 2.8 that way all is working...
with sxos 2.9.4 and firmware 9.2 still having the error with my saved games.

Edit: done emunand on SD files, tried some combinations, and all 2.9.x are having the problem, error when loading savegame or if you dont have the savegame (delete) on the begining when you have to accept the second page of their laws get the error.
 
Last edited:
  • Like
Reactions: Danny89

Danny89

Full Member
Apr 18, 2019
25
3
EARTH
the silence over this complains is getting really worrisome to me. unless they don't have ideas on what to do anymore or the new lawsuits against them is a factor hindering the the bugs fixing and updating of the v2.9.5 sx os.
 
  • Like
Reactions: t1tah1k

t1tah1k

Noob Account
May 17, 2020
3
3
Ukraine
How did you do that please can you guide me on doing so, as I don't want to mess up anything?
Oh, it will be hard to explaine cause I used Kefir - it is a russian language based app collection which includes atmosphere with sigpatches, sx OS and Hekate. I know that you can find something similar in english. Basically you just need to install Hekate and put sx OS and atmosphere payloads to the inner folder. Then just use Recado for Android to pass Hekate payload to the Switch and choose which OS you want to load.
 
Last edited:
  • Like
Reactions: Danny89