Official SX AUTOLOADER Discussion

garyopa

Staff member
Top TX Brass
Mar 25, 2005
48
68
Tropical Island
www.O-P-A.biz
Team [WAIN] is back with another update to their SX Autoloader release!
SXAL3.png

Thanks to our friends at Team [WAIN] they have released an small 'add-on' to our SX OS v2.9.2 which allows you to 'auto-load', what that means now you just find the game you have previously played on your Horizon Home Screen, click on it, and even if it is a dumped cartridge in XCI format, as long as you still have the files on your Micro SD-Card and/or USB HDD, it will now auto-mount the cartridge backup for you and launch it, no more getting upset seeing the 'insert the game card' message, then having to go to Album, launch our SX OS menu, scroll-over and find the game, and mount it and go back.

As long as you have at least mounted your XCI image once via our SX OS menu, now you can just simply click on a XCI Game Icon and it will Auto-Mount and Launch for you directly from the Horizon Home Screen. Is that not amazing! :)

LATEST RELEASE: (Nov. 6th, 2019)

Thousands of SX OS users are loving how easy it is now to mount XCI (dumped cartridges) on their Switch console, thank to the SX AUTOLOADER add-on and now with the v1.20 update, Team [WAIN] brings you an solid release, with stability fixes and faster speed, thanks to hardware accelerated decryption. 🙂

Changelog v1.2
  • General overall stability fixes
  • Fixed bug with to many folders being searched
  • Fixed bug caused by layerfs
  • Fixed bug with long filenames
  • Hardware accelerated decryption
  • Cache directories created if missing
OLDER RELEASE: (Nov. 2th, 2019)

After getting lots of positive feedback on how much easier it was now to play games in XCI format (dumped cartridges) on the Switch console, the team decided to quickly update their recently released SX Autoloader to support USB HDD, so that you can now fully enjoy auto-mounting all your XCI games no matter how vast your collection is or how it is stored.
Changelog v1.1
  • Added USB HDD Support
  • Improved XCI detection
  • Database caching for speed
NOTE: If you have large XCI collection on your USB HDD, first time usage may take a couple of minutes for the database to be built.
IMPORTANT: If you get an Error Code on boot-up, then it means your SD Card has corruption on it, please re-format it and start fresh.
As usual, you can find their latest version of SX Autoloader in the TX Community Resources section, just unpack the new version overwriting the previous files.

To see it in action check out this video below:
 
Last edited:
  • Like
Reactions: Vuttipong

trigao

Noob Account
Dec 14, 2018
1
1
is crashing my console upon reboot
nintendo logo then error code 2011-0301

without it, boots just fine
 

jamer10000

Junior Member
Jan 11, 2019
20
3
Alabama
I copied the unrar files into the root , nothing happened.
do I need to put the files in other location ? the main folder is : SXOS folder which contains "title"
 

Game_Over

Staff member
Top TX Brass
Dec 2, 2010
5,340
138
127.0.0.1
are all of you getting the crash on 9.0.1 ? I need to reproduce this crash to get a solution worked out.

Are you using emunand (and what type) or sysnand ?

The more info you can provide - the better our chances of finding and correcting the problem.

Simply saying "Same here" and "me too" doesn't help us fix anything.

--edit--

I am on 9.0.1 using files emunand and this works perfectly for me. It also works perfectly on sysnand.

I suspect the users with the crash either have weird / custom xci files, custom theme, or some other item on the sd card causing the crash.
 

Game_Over

Staff member
Top TX Brass
Dec 2, 2010
5,340
138
127.0.0.1
I am on ofw 9.01, emunand sx os 2.9.2
Okay this setup alone is not a problem as it has been tested and works fine.

Are you using exFAT? Do you have a custom theme?
 

bernyhome

Noob Account
Oct 8, 2018
3
1
Okay this setup alone is not a problem as it has been tested and works fine.

Are you using exFAT? Do you have a custom theme?
same boot crash here. Need to remove sxautoloader installed files to boot normally.
ofw 9.01, emunand sx os 2.9.2 on sd card.
Yes, Im using exFAT. No custom theme. Default black one.
 

Game_Over

Staff member
Top TX Brass
Dec 2, 2010
5,340
138
127.0.0.1
Okay as we all know exFAT is very problematic on the switch. There is a very high chance you have data corruption on your sd card. So the first order of business in trouble shooting is to get you moved to a FAT32 filesystem.

Back up all your data, format to FAT32, then move your data back.

This will more than likely fix your problem. If you have files larger than 4gb, they will just need split before you can copy them back.
 

18Phoenix

Full Member
Sep 25, 2018
34
8
Works fine using 2.9.2 + FW 9.0.1 + FAT32 MicroSD.
Great improvement, thanks.
Could it be that splitted XCIs are not supported by the Autoloader at the moment ?
What about XCZ files ?
 
Last edited:

Game_Over

Staff member
Top TX Brass
Dec 2, 2010
5,340
138
127.0.0.1
split xci files work fine. I don't have any xcz files, haven't tried. I don't believe that was mentioned as supported with this or sx os.
 

18Phoenix

Full Member
Sep 25, 2018
34
8
split xci files work fine. I don't have any xcz files, haven't tried. I don't believe that was mentioned as supported with this or sx os.
Thanks. I tried one bigger app splitted in 4 parts, xc0 - xc3.
Trying to mount it (in section Games) failed.
Installing it (in section Installer) works.
 

CaptainCPS

VIP Member
Oct 11, 2019
11
8
Puerto Rico
github.com
SXOS v2.9.2 (emuNAND)
FW v9.0.0
SD: exFAT
Format tested: XCI

Result: Working

For those having problems, make sure to completely turn off your switch, extract the files to have this structure in your SD card:

SD:/sxos/titles/00FF0012656180FF/...

Check that is wasn't extracted as:

SD:/sxloader/sxos/titles/00FF0012656180FF/...

Btw, in the "titles" directory a file is created "SXAUTOLOADER.txt" with a log, at least in my case. So maybe it has info on what is wrong for those having problems.

SeeYa!
:D
 
  • Like
Reactions: Alchemy.Gaming

Game_Over

Staff member
Top TX Brass
Dec 2, 2010
5,340
138
127.0.0.1
what are you using to split?

I split my game with sx dumper, and every game I split worked with no problems at all.

If you game won't mount with sx os, then it surely won't work with this autoloader.