OFFICIAL SX INSTALLER V3.01 DISCUSSION

Status
Not open for further replies.

Xecuter

Staff member
Top TX Brass
Dec 6, 2002
11,465
128
Asia
team-xecuter.com
Our popular SX Installer app has been updated today, along with SX Server for Windows!
SX301.png

Today, we bring you the latest version of our very popular SX Installer app, and to make it even more popular, we have added a cool new feature, SMB (Samba) file sharing is now possible, which means you can install NSP/NSZ directly from your Windows PC to your Switch console with ease. We also like to point out that 'Cloud Saves' is now possible, you can directly backup/restore your Game Saves to gdrive, or Samba, and unlike 'Nintendo Cloud Save' feature, this works for all your games! We also updated our SX Server, allowing you to directly use gdrive support with it as well!
🙂


Check out the changelogs below:
SX Installer v3.01 Changelog:
  • Fixed USB HDD support.
  • Fixed Title Key dumping.
  • Improved rendering performance.
  • Added SMB/Windows File Share support.
  • Added ability to re-arrange locations.
  • Added support for "blocked" NSZ installation.
  • Automatically resets required version upon install / uninstall.
  • Input is now accepted from all controllers, not just player one.
  • Added shutdown screen so you can safely exit the application from title mode.
  • Blocked the installation of all modified DLC and Updates with no way to bypass.
  • Fixed bug that allowed users to install 9.0 encrypted titles on lower firmwares.
  • Included auto-install-forwarder and blocked applet mode due to memory constraints.
  • Disabled remembering "standard crypto" option to prevent users from leaving that enabled.
SX Server v1.2 Changelog:
  • Added support for XCI, XCZ, and NSZ
  • Added gdrive support to both SX Server and SX Installer
As usual, you can find the latest versions on our SX Portal Downloads page. That's all for today, Enjoy!

—< Team-Xecuter - Rocking the Switch in 2019 and beyond! >—
 

badpix11

Full Member
Jul 13, 2018
29
3
The changelog sounds really nice but unfortunately some points forced me to revert it back to the last version:

Included auto-install-forwarder and blocked applet mode due to memory constraints.
There is no way to disable the forwarder and/or remove it easly.

Blocked the installation of all modified DLC and Updates with no way to bypass.
I know the risks of modified DLCs and Updates but why is there no way to bypass?
I tested it with Starlink DLC Unlocker and old/new SSB DLCs, looks like I can't install any of the Scene released DLCs
 

Jonny0r

Noob Account
Aug 19, 2019
4
1
Bagladesch
Sounds awesome, i will give it a try, to old versions always need 5-10 minutes to create the database :(

Samba Support sounds really interessting but im scared that the Switch LAN / WLAN is simply to slow for this. When i copy something from PC to Switch due to the FTP then i have usually 1-5mb/s which simply sucks :(
 

Condemned87

Full Member
Sep 25, 2018
44
8
I have installed SX Installer 3.01 and the app were installed to my homescreen without question if I want it. Usually I use SX OS only for XCI Backups of my own games, still using OFW for eshop (to purchase some nice indies). I had deinstalled the Installer immediately after I saw that the app has been installed... but after rebooting into OFW, my switch were instant banned. That's sucks because I never installed a NSP file or so to avoid a ban - SX Installer 3.01 fu**ed me. This is just a info for everyone who also want to use OFW to load game updates and so on - as me before testing installer 3.01 yesterday afternoon. Now I have to use other ways to get updates and my lovely indie games.. that is what I usualy didnt want.
 

johnny9826

Noob Account
Nov 12, 2019
2
1
UK
I need some assistance if anyone can help.
I installed v3.0.1 without issue but when I launch the app it's in Russian althought my console is set to English and region is Europe, it's only when in SX installer is the language changed.

Does anyone have any suggestions

Thanks for your help
 
  • Like
Reactions: Soca90

Game_Over

Staff member
Top TX Brass
Dec 2, 2010
5,573
138
127.0.0.1
I have installed SX Installer 3.01 and the app were installed to my homescreen without question if I want it. Usually I use SX OS only for XCI Backups of my own games, still using OFW for eshop (to purchase some nice indies). I had deinstalled the Installer immediately after I saw that the app has been installed... but after rebooting into OFW, my switch were instant banned. That's sucks because I never installed a NSP file or so to avoid a ban - SX Installer 3.01 fu**ed me. This is just a info for everyone who also want to use OFW to load game updates and so on - as me before testing installer 3.01 yesterday afternoon. Now I have to use other ways to get updates and my lovely indie games.. that is what I usualy didnt want.
You can't mod your switch AND expect to NOT be banned when you connect it to the internet. This is videogame console modding 101.

I'm sorry it happened, but that is the risk you take when modding.
 

kalitbartman

Noob Account
Nov 14, 2018
7
1
You can't mod your switch AND expect to NOT be banned when you connect it to the internet. This is videogame console modding 101.

I'm sorry it happened, but that is the risk you take when modding.
1.52 (which i am using ) and some other versions aren't nsp's and won't ban your console and you can use it while a game is active and save backup works

3.01 is an nsp and you can't use it with a game running it asks you to close it and you can't backup saves or even restore them (and i think you had to backup or restore your saves with the installer while the game is running

if you don't install nsp's you are less likey to or even not get banned

if you install an nsp it's 100% ban
 

noreason4

Noob Account
Nov 9, 2019
2
1
Anywhere
Could you please add an option to install modified DLC? I know the risks but there is no good way to install scene released DLCs now. Thanks!
 

Deymos

Noob Account
Nov 28, 2019
8
1
Spain
Not run in 9.1.0?
I can exe the 3.0.0 version in 2.9.3beta and firm 9.1.0 but the 3.0.1 give me error files...
 
Status
Not open for further replies.