Official SX OS v2.9.2 Beta Discussion

Jolabete

Noob Account
Oct 28, 2019
3
1
France
Hello all, i used sx product since a long time, but haven't update my switch since 8.0.1
My question is, can i turn my switch in ofw mode to update it in 9.0.1 and use the last boot from sx team, and all will work perfectly ?
For moment i see only few games that required me to update so i prefer ask before do a mistake. Thanks.
 

Maxvador

Noob Account
Oct 30, 2019
4
1
FR
Guys ,does anyone has this error to.
"The game cart could not be read
Please remove and reinsert it", with a real cart. When i reinsert it works and if i remove it again and reinsert it it pops the error again,is like 1 error, 1 reads it only on mod.. if i boot on og nand works good, that happened after go to 2.9.2 on 9.0.1
Yes same issue ! unable to use legit cart
the catridge reader still work bad, crash when a game is inserted.
I hope it will be solved soon, same issue :-(
 
Last edited:

ModelZero

Junior Member
Oct 26, 2019
15
3
US
I see they have now moved version 2.9.2 for a stable only release, has this problem now been resolved?
So far they were able to reproduce the error. I'm hoping they have a fix soon. My switch has just been sitting idle for some time.
 

damahala

Noob Account
Jul 19, 2019
8
3
US LA
There seems to have an issue if try to mount XCI file directly from USBHDD while it is still scanning. When you mount XCI directly from Game tab under Album, system will switch back to Switch game listing page but the selected XCI won't mount. You have to wait until scan finished to mount it, but if the hard drive contains many files, it will take long time before you can safely mount the XCI. Switching game will have to restart everything over again, so very inconvenience.
 

ModelZero

Junior Member
Oct 26, 2019
15
3
US
There seems to have an issue if try to mount XCI file directly from USBHDD while it is still scanning. When you mount XCI directly from Game tab under Album, system will switch back to Switch game listing page but the selected XCI won't mount. You have to wait until scan finished to mount it, but if the hard drive contains many files, it will take long time before you can safely mount the XCI. Switching game will have to restart everything over again, so very inconvenience.
I’ve never had that problem before. How many game exactly do you have on your usbhdd? And not sure if it matters or not but which port are you using?
 

Palinkat

Full Member
Apr 5, 2018
34
8
It is not a new issue with latest firmware. Waiting for the USB scan to finish before mounting has always been a problem with a large xci collection
I guess the TX solution is to use autoloader but it still has some issues with filenames.
 

damahala

Noob Account
Jul 19, 2019
8
3
US LA
It is not a new issue with latest firmware. Waiting for the USB scan to finish before mounting has always been a problem with a large xci collection
I guess the TX solution is to use autoloader but it still has some issues with filenames.
thanks. I will study a little on autoloader...
 
Last edited:

diceaurora

Noob Account
Nov 11, 2019
1
1
behind you
Another day, another SX OS update! Today we present you with SX OS v2.9.2 beta.

We've heard multiple times that people are tired of the BETA tag, so if we don't receive any serious complaints this will also soon be known as v2.9.2 stable. Plus of course this release fully supports the latest Nintendo Switch v9.0.1 firmware, if you had not noticed that are previous one did as well!

What's new in this update?



That's it for today, folks! This is probably one of the final releases in the 2.X series of SX OS. We received many suggestions as to what you want to see in SX OS 3.0. Suffice to say, we work hard to bring you all of those, so for now our SX OS 2.9.2 beta is now available on our download page and also as an OTA update using the SX OS builtin updater. What are you waiting for?!

—< Team-Xecuter - Rocking the Switch in 2019 and beyond! >—
Is anyone else having troube lauching God Eater 3 on the latest patch level with sxos 2.9.2? It keeps crashing on me. This used to work when i was runnign sxos 2.8. on firmware 8.0.1. I am on firmware 9.0.1. currently
 

vinson77

Junior Member
Oct 1, 2019
10
3
Philippines
Hi TX Team, since updating to v2.9.2, all of my games freezes. Have already formatted 2 SDXC microsds (1 newly bought 200GB) and started from scratch. Please update me if this issue has been fixed. Thanks in advance.

Update: I have already reverted my boot.bin file back to v2.9.1... played several games a hell out of it until my battery got drained from 100% down to 2%. I can conclude that this error / issue is not present on v2.9.1. You could probably check what makes v2.9.1 so special that it doesn't have this issue.
 
Last edited:

damahala

Noob Account
Jul 19, 2019
8
3
US LA
Not sure if this is only happen to 2.9.2, but the Cheat feature seems to have issue.

If tried to Jump to address to something like HEAP+0x91xxxxxx, it will instead jump to BASE+0x306eXXXXXX range. This makes the modifying or use cheat to not reliable as if the matching result is in this range, the modify will not work.

Search for value seems to be working fine but just the display, and the modify will not work.
 
Last edited:

vinson77

Junior Member
Oct 1, 2019
10
3
Philippines
note: I have bought a new legit Sandisk Ultra Class 10 U1 200GB just last week. I was also able to register my product on Sandisk 10 years Warranty program as my microsd is a legit one.

v2.9.1 did solve my game freeze issue when playing on Handheld Mode. But, as soon as I dock my Switch and start either a XCI image or an installed NSP game... my microsd starts to act weird up to a point that XCI images fails to load, and microsd becomes unresponsive. I haven't got these issues when I was still on ofw 8.1.0 and SX OS 2.8.x. These issues started to persist when I updated my ofw to v9.0.0 and v9.0.1 w/ SX OS v.2.9.2.

Could you help me out with this issue or try to troubleshoot such issue on your end and look for a fix.
 

Ragin' Cajun

Noob Account
Nov 18, 2019
1
1
Canada
Hi Everyone!

I'm on SX OS 2.8 currently but whenever i have tried to use any of the 2.9 versions my system freezes at the lock screen. My SD card is a Sandisk Ultra formatted in FAT32 and everything works on 2.8. Has anyone run into a similar problem? Thanks!
 

000edu

Noob Account
Nov 21, 2019
1
1
Spain
Hi. SXOS 2.9.2 has a bug that produces SX Pro never launches power off payload when AutoRCM is on and you choose "Power off" from NSW menu.
No more SX Pro green and blue lights, just if you press console power button again and dongle starts SXOS ... again. Welcome battery drain!
Hi, I observed the same behaviour in my Switch with SXOS 9.2. How did you solve it?
 

vinson77

Junior Member
Oct 1, 2019
10
3
Philippines
I have completely fixed my random in-game error issues on v2.9.2. Have opened my Switch and reseated my MicroSD Slot. Constant random in-game errors where caused by the loose connection on the MicroSD Slot's Ribbon. I have pulled it out, and made sure that it's firmly fitted right back to its connection slot.
 
Last edited:

Reecey

Junior Member
Oct 10, 2019
10
3
England
@Reecey @High Force @Astupi @oniwabanshu
We are making headway. We have succeeded in recreating the issue and we are now passing it to the devs. Thanks for your patience and understanding with this issue!
I tried today to completely set up a new nintendo account separate from my other nintendo account on my banned switch so they are not linked, now it works all fine if you use the new id without logging into it but soon as you link that id to your nintendo account, log in to use your online features and boot the games they freeze, it doesn't matter what you try soon as you log in that id to a nintendo account it freezes. I also clicked on unlink nintendo account in the user menu settings online so it would unlink all devices, it still didn't make any difference. I am trying hard to find a solution to this problem until it gets fixed I'm struggling. Of course you can use your retail games without issues so it's not all that bad but I would like to get this fixed so I can have all my games in xci format so I don't have to keep carrying around retails cartridges that's the point here. Do you know anyone yet who has managed to find away around this problem?
 
Last edited:

Alchemy.Gaming

Troll Eating Dogs
Mar 11, 2019
102
43
US
I tried today to completely set up a new nintendo account separate from my other nintendo account on my banned switch so they are not linked, now it works all fine if you use the new id without logging into it but soon as you link that id to your nintendo account, log in to use your online features and boot the games they freeze, it doesn't matter what you try soon as you log in that id to a nintendo account it freezes. I also clicked on unlink nintendo account in the user menu settings online so it would unlink all devices, it still didn't make any difference. I am trying hard to find a solution to this problem until it gets fixed I'm struggling. Of course you can use your retail games without issues so it's not all that bad but I would like to get this fixed so I can have all my games in xci format so I don't have to keep carrying around retails cartridges that's the point here. Do you know anyone yet who has managed to find away around this problem?
Unfortunately we have not been updated as to what bugs have already been addressed for the next release. I suspect we won't actually know if it's fixed until release. Sorry it has taken so long, but thank you for your persistence. Thanks to you we were able to identify that this IS a bug in SX OS that needs to be addressed. Rest assured we will keep nagging the devs if it does not get fixed in the next release. Thanks for all your patience and understanding!