Official SX OS v2.9.3 Beta Discussion

Feyr

Noob Account
Dec 14, 2019
7
1
Bahamas
I found it. For me it was because I used a brand new SD Card.
Before using the card, the Switch just asked to update console (and install "Nintendo" Folder). Because I already was in 9.1.0, I did the update. All if fine now.
 

Jamesmon

Noob Account
Dec 26, 2019
1
1
Mexico
I update my console to 2.9.3 without problems, but now it doesn't work in dock mode, ofw works fine, anyone have the same problem?
 

medi01

Noob Account
Jul 25, 2018
7
3
Using sysnand.
Upgraded to 9.1 using no-fuse-burn method. (from 7.0.1)
Upgraded SX OS to the latest beta (else it went black)

Most games work, but some (perhaps all with DLC?) stopped, Legend of Zelda is trying to "download" something from internet.

Any clues how to fix it?

PS
Using exfat card since 7.0.1.
 

medi01

Noob Account
Jul 25, 2018
7
3
Using sysnand.
Upgraded to 9.1 using no-fuse-burn method. (from 7.0.1)
Upgraded SX OS to the latest beta (else it went black)

Most games work, but some (perhaps all with DLC?) stopped, Legend of Zelda is trying to "download" something from internet.

Any clues how to fix it?

PS
Using exfat card since 7.0.1.
Nobody? :(
 

centcom

Noob Account
Jan 8, 2020
2
1
USA
having an issue I've only seen with this release (maybe coincidence), I get an error loading the 2 games I tried (Witcher III NSP and The Pinball Arcade NSP), these games install but won't start with my usual local user account, if I use any other local user account the game will load up fine, never seen this before until now, thought maybe it was version related but maybe not (I did try deleting the game's save data on my user account save data and that doesn't fix it)
 

faria.jonathan

Noob Account
Jan 8, 2020
1
1
Brasil
Not working subtitles in this version 2.9.3 beta?

My console is in version 9.1.0 and installed SXOS 2.9.3 beta already put everything in the titles folder and does not work how to get? or does not subtitles work?
 

moggle

Noob Account
Jan 18, 2020
3
1
usa
Mine problem is totally different. Update to 9.1.0.
1.If I copy more than 3-4 game, the fifth and so one is appeared white box can not be install.
1st I think it was bad xci file , but it wasn't. IF I deleted all and copied the suspicious white box file that could not be install previously, then it now can be play.
2. I can not use SX installer, it appeared white box too. and if I try to open it, error 2168-0002 force me to shutdown.

To sum up, I can only copy and play 3-4 games top, and I can not open SX installer. 2168-0002 force me to shutdown.
 

Laeryo

Noob Account
Jan 26, 2020
2
1
France
I found it. For me it was because I used a brand new SD Card.
Before using the card, the Switch just asked to update console (and install "Nintendo" Folder). Because I already was in 9.1.0, I did the update. All if fine now.
I’m having the exact same issue. Just to be certain: how must you update the firmware in this case ? Did you boot using RCM then pick OFW ang go through the “official” process ?
 

Benthrottle

Noob Account
Feb 16, 2020
2
1
Brazil
Odd bug.

Whenever I try to open the Album, or even the Controller Setup menu WHILE playing a game (from home button), OS crashes into 2003-0008 error.

Gotta close the game first, before messing around with other stuff.

This didn't happen before with 2.9.2.
 

Benthrottle

Noob Account
Feb 16, 2020
2
1
Brazil
I don't want to be a bitch flooding and all but... damn, WORST thing I did was updating it to 2.9.3 Beta from 2.9.2. Thing is totally broken.

Everything was rock solid. Now even some games give me the same 2003-0008 or 2345-0032 error. Man, I can't play my Dead Cells anymore, THAT SUCKS big time, I'm really pissed.

You know. I work in another town. 4 hours in transit everyday. Playing my Switch helps a lot... Thing is f'up man.

If no one gives me a solid answer besides "it must be your sdcard", I'll switch to Atmosphere when I have Time to fiddle around with it. F this.

*
NVM, since no one gave a F, I rolled back 9.0.1, transfered emunand to Atmosphere, updated to 9.1.0 again, and guess what? Everything fully working.
As constructive criticism: There's no problem if you can't keep up with the OFW releases. Just do the f job right. I actually paid for this sh, now I'm using a free solution. FREE, that's f ridiculous.
Anyway, I'll miss XCI support though.
 
Last edited: