Official SX OS v2.9.4 Beta Discussion

Xecuter

Staff member
Top TX Brass
Dec 6, 2002
11,470
128
Asia
team-xecuter.com
Yesterday, we saw the release of Switch firmware v9.2.0.

We didn't want to keep you waiting, so today we bring you support for this update in SX OS v2.9.4!

SXOS294.png

That's all we have for today!

SX OS v2.9.4 beta is now available on our website or through the online updater built into SX OS.

Stay tuned for more SX OS and SX Core news!

—< Team-Xecuter - Rocking the Switch in 2020 and beyond! >—
 
  • Like
Reactions: prcszcmh

Reecey

Full Member
Oct 10, 2019
25
3
England
xci online freeze bugs still present in this 2.9.4! when are you going to fix this issue seen as though in my opinion it is a huge flaw in your cfw but your obviously not bothered in Fixing it! It’s been about 6 months now since the bugs. been present in 9x firmware and you cannot tell me you haven’t had the time to fix it?

By the way I will keep flooding your forum with this issue & keep reminding TX until it’s fixed!
 

BlueSn00w

SXOS 2.9.2 | 8.1.0
VIP Member
Sep 23, 2017
28
8
sn00wconsoles.com
xci online freeze bugs still present in this 2.9.4! when are you going to fix this issue seen as though in my opinion it is a huge flaw in your cfw but your obviously not bothered in Fixing it! It’s been about 6 months now since the bugs. been present in 9x firmware and you cannot tell me you haven’t had the time to fix it?

By the way I will keep flooding your forum with this issue & keep reminding TX until it’s fixed!
they are focused on something much more important. ever hear of the sx core bud?
 

Hackerjac

The Minifigure
Staff member
Troll Eating Dogs
Jun 2, 2010
1,406
108
Denmark

spartin03

Noob Account
Oct 4, 2018
2
1
My switch updated to 9.2 and I have auto update turned off. And I put on the 2.9.4 beta and it shows the xsos logo and then black screen during bootup. Need help
 
  • Like
Reactions: DreayCalice

nicc83

Noob Account
Sep 17, 2018
6
1
xci online freeze bugs still present in this 2.9.4! when are you going to fix this issue seen as though in my opinion it is a huge flaw in your cfw but your obviously not bothered in Fixing it! It’s been about 6 months now since the bugs. been present in 9x firmware and you cannot tell me you haven’t had the time to fix it?

By the way I will keep flooding your forum with this issue & keep reminding TX until it’s fixed!
Dude, you've posted 16 times on the forum. That's more a drip than a flood
 

cutterjohn

Noob Account
Nov 21, 2019
2
1
somewhere
they have plenty of time to work on sxos, which they'll need for core anyways. It's not like they're going to be shipping any cores in the near future, or have you phailwhaled on news?
 
Last edited:

Reecey

Full Member
Oct 10, 2019
25
3
England
Dude, you've posted 16 times on the forum. That's more a drip than a flood
“Dude” 16 times is obviously not enough even after 4 sxos builds later I might have to say it 16 times more! I know it sounds a bit monotonous I agree but if you don’t keep ramming it home then it will never get done!
 
Last edited:

nxhoang90

Noob Account
Mar 11, 2020
2
1
Vietnam
Did anyone get a problem when trying boot into the SX OS boot menu? I couldn't boot into SXOS BOOT when I've created EMUNAND, even though I tried to follow to the instruction: Press the + but then Press Power, my device boot straight into SXOS CFW, skipped to BOOT MENU
 

Herdayu

Noob Account
Mar 11, 2020
3
1
Indonesia
I got a problem which is whenever I insert the game cartridge into the cartridge slot on sx os(cfw boot) it often cannot be read and it says that the game card cannot be read please remove or reinsert the game card and sometimes it can be read but most of it cannot be read but when I tried to insert the cartridge on OFW boot it works fine. Could you please help me, what am I supposed to do to make the cartridge works fine in CFW like it worked before on SX OS of the older version??
 

nxhoang90

Noob Account
Mar 11, 2020
2
1
Vietnam
I got a problem which is whenever I insert the game cartridge into the cartridge slot on sx os(cfw boot) it often cannot be read and it says that the game card cannot be read please remove or reinsert the game card and sometimes it can be read but most of it cannot be read but when I tried to insert the cartridge on OFW boot it works fine. Could you please help me, what am I supposed to do to make the cartridge works fine in CFW like it worked before on SX OS of the older version??
same problem. But I could not load XCI files from CFW, it was announced: "Game card cannot be read...." Holy moly :((
 

Herdayu

Noob Account
Mar 11, 2020
3
1
Indonesia
same problem. But I could not load XCI files from CFW, it was announced: "Game card cannot be read...." Holy moly :((
It's strange. And I thought that my slot cart need to be repaired but when I tried to insert the cart on OFW it works fine. Btw my FW is 9.2 and sxos 2.9.4. So I think it matters to me since everytime I want to play the game from cart I need to reboot into the OFW.😔
 

An0n03

Noob Account
Apr 27, 2019
3
1
france
Hi, it is possible to make up to date plugin ldn_mitm on the next release ? thanks

Edit: nobody encounters problems injecting payloads on the last beta and the last Fw ?
Like lockpickrcm ?
 
Last edited: