Official SX OS v3.0.5 Beta Discussion

hayate188

Noob Account
May 1, 2020
3
3
Brazil
You need to update the OFW on sysNAND via the official method.

You can use ChoiDujourNX to update emuNAND to 10.2.0 and everything will work fine.
I would like to know if i need to use that function to
Thanks TX team for the quick update! 💪

I have updated my Mariko to SX OS v3.0.5 though manual download from SX website and copy of the new "boot.dat" to my FAT32 SD card, then updated the CFW on emunand to FW10.2.0 with ChoiDujourNX (keeping the OFW that I don't use to FW10.1.0)

Everything was done flawlessly and is working fine so far. 😀
Can you awnser how did you update your emudand on sx core, pls?

 

BL4K3Y

VIP Member
Top Poster Of Month
Jul 7, 2010
13,062
118
At Home
I would like to know if i need to use that function to

Can you awnser how did you update your emudand on sx core, pls?
You should boot in to OFW first and update sysNAND to 10.2 before doing anything with emuNAND.

You can then use ChoiDujourNX to update emuNAND to 10.2 which means it will match sysNAND OFW.

If you do a Google search for "ChoiDujourNX Tutorial", you will find detailed instructions explaining how to use it to update emuNAND.
 

MomZo

Loyal Member
Jul 7, 2020
305
28
Vietnam
I would like to know if i need to use that function to
Can you awnser how did you update your emudand on sx core, pls?
Find on Google the official Nintendo Switch firmware 10.2.0
Copy the folder containing all the update files at the root of your SD card.
Copy ChoiDujourNX.nro in the "switch" folder of your SD card.
Boot to CFW on emuNand (don't do it on sysNand) and launch ChoiDujourNX. Select the folder containing the update, select 10.2.0 (exFAT), hit "start installation".
Reboot your Switch and your CFW should be updated.

Had the same issue. I had to enable installing 'unsigned code apps' from tinfoil (*** version) options, then I was able to properly install Super Mario 3D all Stars + the 1.01 update
It is normal as the Mario 3D All Stars NSP from Tinfoil is coming from a modified XCI, so you cannot install it except if you enable "unsigned code apps installation".
 

rafamf

Noob Account
Apr 4, 2020
5
1
Brazil
Is emuNAND enabled?
Yes

If you boot in to SX OS recovery and select "Boot Custom FW", do you still see the error code?
Yes

If the error code still shows, you might want to consider re-formatting your SD card to FAT32 using GUI Format and start over (put boot.dat and license.dat on the SD card, boot in to SX OS recovery and create a new emuNAND).
Before I tried that, I erased all folders from SD Card, one by one, and it worked once I erased sx os folder. Strange because it was working before the update (I was on SX OS 3.0.2), and there was no change on contents.

---------------------------------------------------------------------------------------------------------------------------------------------------------------

Got it working by erasing contents of sx os / titles folder.
 
Last edited:

huixia0010

Noob Account
Apr 26, 2020
7
1
China
try using a capture card then take screenshot from the video or try to find video on youtube
Yeah, Thank you for your reply. I have never used a video capture card, are you sure it can capture SX OS RCM model?
I think if it has signal output, I can see the RCM screen in TV, but it seems not output video signal when it's in RCM model.
If the answer is yes, I'wll buy one.
The video in youtube is still not refined enough.
Thank you for your reply again ^_^
 
Last edited:

optantic

VIP Member
May 2, 2010
619
48
Yeah, Thank you for your reply. I have never used a video capture card, are you sure it can capture SX OS RCM model?
I think if it has signal output, I can see the RCM screen in TV, but it seems not output video signal when it's in RCM model.
If the answer is yes, I'wll buy one.
The video in youtube is still not refined enough.
Thank you for your reply again ^_^
oh yeah, you were right, there is no video output from the dock until is boots to Horizon (haven't thought of that).
I guess the nex best method is to setup a steady camera and capture the pictures in the dark
 

tommapar

Noob Account
Sep 18, 2020
1
1
Argentina
Hi, I'm kinda new to all this updating thing.

Let's say I want to risk free update everything to the latest FW. I have SX OS 3.0.5 already.

Now, I don't have a lot of space on my SD Card (11gigs to be precise), and I've been trying to understand everything from this thread. What I've gathered so far is that sysNand is like, say, an OS image of your regular switch's working FW. emuNand would be like a carbon copy you can f**k with and break without risking your switch become a paperweight, since its only a copy of the real thing.

So to update the thing completely I would have to get my emuNand up to date with the OFW up to 10.2.0 and the CFW up to 3.0.5.

Thing is, I don't know if I'm running emuNand or sysNand, and I don't know what the step by step would be to do it safely without blowing any fuses, if that can actually done.

I bought a Switch and it already came with SX OS installed, so I actually know next to nothing on how to proceed here.

Thanks in advance to anyone that replies to this.
 

deepakcg

Noob Account
Sep 18, 2020
1
1
india
hey all need help pls.... disaster happened....

I have a banned switch which has SX Lite mod chip and everything was working fine... today when I booted my console I received a pop up asking me to update software, unknowingly i clicked on update, the software got update and console does not boot now... its completely blank

I was on SX OS 3.0.4 beta

please can someone help me
 

MomZo

Loyal Member
Jul 7, 2020
305
28
Vietnam
hey all need help pls.... disaster happened....

I have a banned switch which has SX Lite mod chip and everything was working fine... today when I booted my console I received a pop up asking me to update software, unknowingly i clicked on update, the software got update and console does not boot now... its completely blank

I was on SX OS 3.0.4 beta

please can someone help me
Update to SX OS v3.0.5 beta. 😉
 

terrypku

Noob Account
Jun 28, 2019
4
1
Kunming, Yunnan, China
I think the new battery policy might cause a bug. Every time I shut down the console from the custom firmware, and try to boot the original one. The console will be stuck in a black screen after the nintendo logo. I have to hold the power button for a long time, then boot again to enter the original firmware.
 
Last edited:

gusttatsuke

Noob Account
Sep 19, 2020
1
1
Brazil
Hello, first of all I would like to thanks the entire team behind the TeamXecuter.
Today I updated my SXOS to 3.0.5beta and then my FW to 10.2.0, but for my surprise I got blackscreen as soon a booted my NintendoSwitch.
The solution I figured out it was that I had to format my SD card from exFAT to FAT32, later my switch booted just fine and I'm already installing the new M AllStars game.

Thanks you all, I hope this helps someone out there.
 

xs4all

Junior Member
Nov 28, 2018
18
3
37°16'55.2"N 115°47'58.6"W
Just a tip for those that use SysNand and EmuNand.

For me, my EmuNand is OFFLINE and in Flight Mode, and I change the theme to Dark, that way I know that Im in EmuNand. I left my SysNand as default White theme. This way I wont accidentally try and go online in EmuNand, risking Ban.
I do all my online stuff on SysNand, and all my dirty stuff on EmuNand.
 

huixia0010

Noob Account
Apr 26, 2020
7
1
China
oh yeah, you were right, there is no video output from the dock until is boots to Horizon (haven't thought of that).
I guess the nex best method is to setup a steady camera and capture the pictures in the dark
OK, So far, there is no better solution, thank you for your reply. Have a nice day^_^
 

NSWHero

Full Member
Jul 23, 2020
33
6
Europe
LayeredFS is broken :( I keep getting errors trying to start the game.
Please fix!

Also Black ScreensOf Death (not starting after the xecutor logo or not booting at all for a while, and suddenly it works again) since the latest update. Please fix as well.

Battery drain is also not solved, it's evne worse then on 3.0,4, Installing some backups (about 40 min install with Awoo) took battery life from 58% to 1% and turned off I did not have that issue with 3.0.4.
Please fix as well.
 
Last edited:

vliegen

Noob Account
Apr 27, 2019
8
1
nederland
I've updated my switch with choi now with 3.0.5 sx 10.2.0 on emunand but every time the sd card has been out I try to boot the switch honor he goes up to the Nintendo logo and it doesn't go any further then I have to hold the power button for 20 seconds and then it runs further I haven't done anything wrong anyway greeting