Official SX v3.0.2 Beta Discussion

Xecuter

Staff member
Top TX Brass
Dec 6, 2002
11,468
128
Asia
team-xecuter.com
Another day, another update.

Following the release of SX OS 3.0.0 beta we got a lot of feedback from the community again. Today we are releasing SX OS 3.0.2 Beta to address some important issues.
  • Fixed error 2162-0002 game crashes (v3.0.2 only, v3.0.1 been purged)
    We introduced a regression in SX OS 2.9.5 which made some games crash with error code 2162-0002 (when accessing in game manuals and such). This has been addressed and resolved.
  • Fixed savedata bug
    In some instances game progress would not be saved correctly. This behavior could be observed in "castle crashers" (for example). This has been tracked down and resolved!
  • Reworked "GPT Repair" functionality for big-NAND users
    Some people with bigger NAND chips reported not being able to boot into SX OS with our latest update. Affected users should use the "GPT repair" option in the SX OS boot menu (Under options -> NAND) which has been revised to fix the partition table for people with bigger capacity NAND chips.
  • Popular extensions working again
    Popular extensions to SX OS like SX Autoloader, Tesla Overlays and sys-clk overlay are fully working again!
  • Reboot to payload functionality restored
    You can now reboot to any payload again. (Only for Erista consoles)
  • EmuNAND on eMMC working again
    We got reports of EmuNANDs stored on eMMC no longer working, this has been addressed and fixed.
  • Many other minor stability improvements
    General system stability improvements to enhance the user’s experience.
That's all for today. We are working hard to bring more innovative and exciting things to your Switch, stay tuned!

—< Team Xecuter - Pushing the limits of every Switch in 2020 and beyond ! >—
 

RomikB

Full Member
Sep 24, 2018
39
8
SX OS upgrade from inside SX OS not working.
Not from 3.0.0 to 3.0.1.
Not from 3.0.1 to 3.0.2
 

Animefighters88

Full Member
Jun 7, 2020
37
8
Usa
Just wanted to say thanks team x. Befor my emunad was not working on sxos 3.0.0 it would boot me into my main sys nad now she works love u guys been here sens day0 with sxos . Everything is working like it should I'm on FW 10.0.3 WITH sxos 3.0.2 thanks aging very happy
SX OS upgrade from inside SX OS not working.
Not from 3.0.0 to 3.0.1.
Not from 3.0.1 to 3.0.2
Just dl from the web that's what I do. It goes a lot faster
 

akram2019

Noob Account
Jun 16, 2020
2
1
germany
hi

can someone help me i think i made a mistake by updating to 3,0,2 and to 10,0,0,4 FW that i already had an error code 2168-0002
i am using an old switch with emunand i followed the instructions from team excuter by repairing the GPT but the result is the same
i hope someone can help
confirmed still not working
Sys 10.04 on 3.02 Emu 10.04 with autoloader confirming it is working. THank you for a great Job!
might you be able to help me cuz i updated to 10.0..4 with 3.02 but now am having an issue with error code
 

Reecey

Full Member
Oct 10, 2019
62
8
England
I will say for the quick turn around of v3.0.2 TX, kudos! and this build seems to be working very well so far.
 
Last edited:

mlnm

Noob Account
Jan 7, 2019
3
3
Brazil
Hello!

First, I would like to thank you for the great work you have been doing.

Second, I came here to report a problem that was already happening with version 3.0.0 of SXOS along with FW 10.0.2 and remains in the newest updates for both SXOS and Switch, 3.0.2 and 10.0.4 respectively.

The console's reboot function is not working, it was necessary to place the dongle to restart the console with SXOS.

To make things worse, in 3.0.2 my switch doesn't start even with the dongle and the jig. When I was trying to start the Switch the screen goes black and in the dongle a green light is constantly on.

Can someone help me?
 

dvpmike

Junior Member
Oct 9, 2018
18
3
Hello!

First, I would like to thank you for the great work you have been doing.

Second, I came here to report a problem that was already happening with version 3.0.0 of SXOS along with FW 10.0.2 and remains in the newest updates for both SXOS and Switch, 3.0.2 and 10.0.4 respectively.

The console's reboot function is not working, it was necessary to place the dongle to restart the console with SXOS.

To make things worse, in 3.0.2 my switch doesn't start even with the dongle and the jig. When I was trying to start the Switch the screen goes black and in the dongle a green light is constantly on.

Can someone help me?
Mine did that too. Mine got fixed by downloading the 3.0.2 firmware from the website then replacing the boot.bin on the memory card. Updating to 3.0.2 doesn't seem to work and it will only give you a black screen. So just go to their website and dl the 3.0.2 from there and put it on your memory card should fix it.
Mine did that too. Mine got fixed by downloading the 3.0.2 firmware from the website then replacing the boot.bin on the memory card. Updating to 3.0.2 from the switch doesn't seem to work and it will only give you a black screen. So just go to their website and dl the 3.0.2 from there and put it on your memory card should fix it.
 
  • Like
Reactions: mlnm

macnemo

Noob Account
Dec 15, 2018
7
1
yes I confirm, I downloaded the file from the website (instead of updating from the switch) and now it works.
 

mlnm

Noob Account
Jan 7, 2019
3
3
Brazil
Mine did that too. Mine got fixed by downloading the 3.0.2 firmware from the website then replacing the boot.bin on the memory card. Updating to 3.0.2 doesn't seem to work and it will only give you a black screen. So just go to their website and dl the 3.0.2 from there and put it on your memory card should fix it.
Thank you very much for the tip, it worked here too, but the reboot problem remains.
 
  • Like
Reactions: dvpmike