Status Code: 3151-xxxx-xxxx-xxxx-xxxx

wantin2mod

VIP Member
May 28, 2005
145
23
On the North American Continent
I picked up a 360 that is displaying Status Code: 3151-xxxx- etc.
The console is turned on and it looks like it's trying to install the update. The console then reads: update was not able to be found on your hard drive. Please reinstall hard drive and try again.
Status Code: 3151-xxxx-xxxx-xxxx-xxxx.
The warranty seal is missing so I've taken the box apart. It has a BenQ drive. I checked the drive in JF and it's said to have the stock firmware. I have read from many different sites on how to fix this issue yet I've had no resolve. Google is my friend I know ( as I've G.T.S [google that sh*t] this topic to death).
Things I have tried:

*Cleared the cache (pressing sync button as I've booted the console).
* Downloaded the update from M$ and put it on a 4gb flash drive then put that drive in the 360.
* Tried using many different discs in tray upon boot: Battlefield 3, Halo Anniversary, MW3, GOW3. Update did not finish with these discs.

I don't have the hard drive that was originally on this console when I received it. I'm guessing the owner wanted to sell the hard drive.

What can I do to fix and exercise this status code?

Regards,
wantin2mod

---------------------------------------------------------------------------------------


Just wanted to post the below link that is similar to the above story which ended in success!

-------> Success thanks to TX! <-------

.
 
Last edited:

wantin2mod

VIP Member
May 28, 2005
145
23
On the North American Continent
Sorry, I can't get you the exact code at this time as I am at work (I could only recall the 1st 4 numbers). I will post the exact Status Code when I get home. I have searched for a couple days on this and have tried all the fixes I've found but then again most of the fixes I did find were old posts. :(

Ubergeek - I apologize for the zillionth and one time in asking. I am feeling Ubernoob. :redface:

Been out of the mod scene for a couple of years. Needles to say, I'm disconnected and rusty.

Thank you for bearing with me in this.:)
 

wantin2mod

VIP Member
May 28, 2005
145
23
On the North American Continent
Attached is a picture of the Status Code on the screen. As you can see it's: 3151-351F-B380-0F00-C000-000E


Here is what JF gave me about the drive on my second read:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

JungleFlasher 0.1.92 Beta (304)

Session Started Sun Apr 08 22:40:44 2012



This is a Wow 64 process running on 8 x 64 bit CPUs

X360USB PRO detected :cool2:, Version 0.18



Found 1 I/O Ports.

Found 2 Com Ports.

Found 4 windows drives C: D: E: F:

Found 2 CD/DVD drives D: E:



portio64.sys Driver not Installed

PortIO unloaded.

Drive is Benq..

Drive is Benq..

Drive is Benq..



Sending Magic Keys to Drive on port 0x0000

.................................................

Done!

Sending Vendor Intro

Requesting Device ID

Manufacturer ID: 0xC2

Device ID: 0x11

Flash Name: MXIC(MX25L2005)

Flash Size: 262144 bytes

Sending Vendor Intro to port 0x0000



Serial flash found with Status 0x73



Sending Device ID request to port 0x0000

Manufacturer ID: 0xC2

Device ID: 0x11

Flash Name: MXIC(MX25L2005)

Flash Size: 262144 bytes



Getting Status from port 0x0000

Serial flash found with Status 0x73



Reading Bank 0: ................

Reading Bank 1: ................

Reading Bank 2: ................

Reading Bank 3: ................



Dumped in 8326mS



Benq Dump file saved to BENQ-OFW - 2nd dump.bin

Loading firmware from buffer

Inquiry string found

Identify string found

Drive key @ 0xE030 B0B00D2E134590A57xxxxxxxxxxxxxxx

Firmware Osig: [PBDS VAD6038 0442]

Firmware is: Stock

Key database updated






@ Ubergeek - I assume I can find this fw at the usual places?




Is there a way I can break the code down so I can understand what it's describing?





.
 
Last edited:

Martin C

VIP Member
Jan 10, 2004
36,015
0
Scotland, UK
www.team-xecuter.com
It's trying to apply the 13599 update. So first off, download this and put on a USB stick (folder called $SystemUpdate).

Next, flash your drive back to stock using the pre-13146 firmware for Benq.

Once back to stock, insert the USB key you made and turn on. It should complete the update.
 
  • Like
Reactions: wantin2mod

wantin2mod

VIP Member
May 28, 2005
145
23
On the North American Continent
I appreciate your help Martin. As I'm looking in the "Stock" firmware (which has folders named Pre_13141 and Post_13141), which BIN file do use to get me to pre 13146?

I have used a hexidecimal converter and came up with the dash version of 13599 on the status code. I'm just needing understanding on the BIN file.

Thank you.
 
Last edited:
  • Like
Reactions: Dreamreaper

AMIT

VIP Member
Nov 30, 2011
943
68
INDIA
I appreciate your help Martin. As I'm looking in the "Stock" firmware (which has folders named Pre_13141 and Post_13141), which BIN file do use to get me to pre 13146?

I have used a hexidecimal converter and came up with the dash version of 13599 on the status code. I'm just needing understanding on the BIN file.

Thank you.
if i remember correct then it would be orig-64930C-E030.bin found at pre 13141 folder !
 
Last edited:

axee44

VIP Member
Nov 8, 2011
330
48
York,UK
if i remember correct then it would be LT + 1.1 for BenQ (12625 dash)!

Xbins- /XBOX 360/firmware/hacked firmware/Benq VAD6038/_old/Benq_iXtreme_LT_v1.1.rar

hope this helps !
Why would you advise him to use LT+ for failed dash update??

OP - try to flash your benq to stock using orig-64930C-E030.bin from pre 13141 folder (your drive is currently on post 13141 fw according to your jf log).This might work just fine but i've got a strange feeling there might be more to it according to this:
xxxx-xxxx-1xxx-xxxx-C000-007B
xxxx-xxxx-xxxx-xxxx-C000-000E
xxxx-xxxx-xxxx-xxxx-C000-0010
xxxx-xxxx-xxxx-xxxx-C000-007F
The console needs to be repaired. Submit an online repair request.

Edit: also try plugging in hdd if you have one at hand - error message shows it needs hdd and i read some people had a success in doing that with this error code.
 
Last edited:
  • Like
Reactions: wantin2mod

AMIT

VIP Member
Nov 30, 2011
943
68
INDIA
Why would you advise him to use LT+ for failed dash update??

OP - try to flash your benq to stock using orig-64930C-E030.bin from pre 13141 folder (your drive is currently on post 13141 fw according to your jf log).This might work just fine but i've got a strange feeling there might be more to it according to this:
xxxx-xxxx-1xxx-xxxx-C000-007B
xxxx-xxxx-xxxx-xxxx-C000-000E
xxxx-xxxx-xxxx-xxxx-C000-0010
xxxx-xxxx-xxxx-xxxx-C000-007F
The console needs to be repaired. Submit an online repair request.
sorry, i though he is asking for pre-13141 (C)FW !
 
  • Like
Reactions: wantin2mod

RROD!

VIP Member
Apr 13, 2011
787
0
ok ive seen this on the net
1.Remove any disc from the console.
2.Leave the disc tray open.
3.With the disc tray open, remove the power cord from the back of the console.
4.Plug the power cord back into the console. Do not turn the console on yet.
5.Gently push the disc tray about half-way back into the console.
6.Push the power button on the console.

not sure if you tried this yet ??also are you sure it is the right drive as i got one from ebay the same not sure of the code but was a old xenon some guy had just put some other drive in the console on stock so i rgh the console to get the keys and it all works good now... again i maybe way off but worth a look maybe
 
  • Like
Reactions: timner4

wantin2mod

VIP Member
May 28, 2005
145
23
On the North American Continent
Thanks guys, I appreciate your help.

I was just trying to figure out which "pre" firmware to use. As I can see now, it looks as if the first 4 characters of the dvd drive key correlates to which pre firmware to use (thanks AMIT, and yes....want to get the console back to stock...or as close as possible). Makes total sense now.

I have not yet flashed the drive with the matching pre firmware.

@ axee44 - I do have a spare hardrive to use which I had plugged in when trying the update from a usb drive. I had no result. BUT. . . .I also hadn't reflashed the drive yet with the matching pre-firmware.

@ RROD - I did see this fix online but have not yet had the chance to try it. Also, I don't know if this is the original dvd drive that came with the console. If I have to gear up and RGH the console, I will (been looking forward to trying one as I've never done one before). Thanks for posting!!


After I get off work, I'll post my findings having given all the above a go.



.
 

wantin2mod

VIP Member
May 28, 2005
145
23
On the North American Continent
Alright guys, here it is. I flashed my drive to the pre 13141 orig-64930C-E030.bin file. Here is my JF log:


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

JungleFlasher 0.1.92 Beta (304)

Session Started Wed Apr 11 09:07:45 2012



This is a Wow 64 process running on 8 x 64 bit CPUs

X360USB PRO detected :cool2:, Version 0.18



Found 1 I/O Ports.

Found 2 Com Ports.

Found 4 windows drives C: D: E: F:

Found 2 CD/DVD drives D: E:



Drive is Benq..

Drive is Benq..

Drive is Benq..



Sending Magic Keys to Drive on port 0x0000

.................................................

Done!

Sending Vendor Intro

Requesting Device ID

Manufacturer ID: 0xC2

Device ID: 0x11

Flash Name: MXIC(MX25L2005)

Flash Size: 262144 bytes

Sending Vendor Intro to port 0x0000



Serial flash found with Status 0x73



Sending Device ID request to port 0x0000

Manufacturer ID: 0xC2

Device ID: 0x11

Flash Name: MXIC(MX25L2005)

Flash Size: 262144 bytes



Getting Status from port 0x0000

Serial flash found with Status 0x73



Reading Bank 0: ................

Reading Bank 1: ................

Reading Bank 2: ................

Reading Bank 3: ................



Dumped in 8336mS



Benq Dump file saved to BENQ-OFW-preflash.bin

Loading firmware from buffer

Inquiry string found

Identify string found

Drive key @ 0xE030 B0B00D2E134590A57xxxxxxxxxxxxxxx

Firmware Osig: [PBDS VAD6038 0442]

Firmware is: Stock

Key database updated





Loading MTK_Flash source file

Loading firmware file C:\Users\\Desktop\JungleFlasher.0.1.92.Beta(304)\JungleFlasher v0.1.92 Beta (304)\firmware\orig-64930C-E030.bin

MD5 hash: bb9f32e8b61f6da5fxxxxxxxxxxxxxxx

Inquiry string found

Identify string found

Drive key @ 0xE030 00000000000000000000000000000000

Firmware Osig: [PBDS VAD6038-64930C ]

Firmware is: Stock

Key data saved to C:\Users\\Desktop\BenQ Blue\Key.bin



Spoofing Target

DVD Key copied to target

Inquiry string copied to Target

Identify string copied to Target





Target f/w saved as: Benq_CFW-stock-pre1341.bin



Getting Status from port 0x0000

Invalid Status 0x80



Getting Status from port 0x0000

Invalid Status 0x80

Sending Vendor Intro to port 0x0000

Status 0x80

Drive is Benq..

Drive is Benq..

Drive is Benq..



Sending Magic Keys to Drive on port 0x0000

.................................................

Done!

Sending Vendor Intro

Requesting Device ID

Manufacturer ID: 0xC2

Device ID: 0x11

Flash Name: MXIC(MX25L2005)

Flash Size: 262144 bytes

Sending Vendor Intro to port 0x0000



Serial flash found with Status 0x73



Sending Device ID request to port 0x0000

Manufacturer ID: 0xC2

Device ID: 0x11

Flash Name: MXIC(MX25L2005)

Flash Size: 262144 bytes



Getting Status from port 0x0000

SPi flash found with Status 0x73



Sending Chip Erase to Port 0x0000

Erasing:

Writing target buffer to flash

Writing Bank 0: ................

Writing Bank 1: ................

Writing Bank 2: ................

Writing Bank 3: ................



Flash Verification Test !

Reading Bank 0: ................

Reading Bank 1: ................

Reading Bank 2: ................

Reading Bank 3: ................

Write verified OK !



Sending Vendor Outro to port 0x0000

Drive is Benq..

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

After the flash I put the DVD drive back in the console. Then I took my 4GB flash-drive freshly formatted to FAT32 with the 2.0.13599.0 update inside a folder named $systemupdate and put that in the usb port on the back of the console.

I then plugged in the console and turned it on.
Kazaam!!!​


The console booted and started to apply the update. During the update I was informed that I needed more memory space to get the update installed to the console (no hard drive). Luckily, I had a spare 512mb memory card lying around and used that to finish the update.

The console is back!!

Thanks guys for ALL your input and helping me getting this going!!!

Now I have to fix the dvd drive so it won't be stuck on Eject. Ugh.
 

mechgamer123

VIP Member
Sep 11, 2011
183
0
Did you try what rrod suggested? I had an error similar to that but I'm not sure if it was exactly that one and that fixed it.
 

wantin2mod

VIP Member
May 28, 2005
145
23
On the North American Continent
Yes I did try RROD's method but not the part about leaving the tray half way out.

I have got the console booting and the dvd drive working after I have cleaned it up and replaced the laser. Great ejecting and reading discs quickly.

Bad part: console will not play 360 games, only movies. So the dvd drive that was in this console WAS NOT the matching drive. Meaning I have no dvd drive key!

Crap.

.
 

Justice1231

VIP Member
May 4, 2011
1,005
0
Adelaide, Australia (down south)
Yes I did try RROD's method but not the part about leaving the tray half way out.

I have got the console booting and the dvd drive working after I have cleaned it up and replaced the laser. Great ejecting and reading discs quickly.

Bad part: console will not play 360 games, only movies. So the dvd drive that was in this console WAS NOT the matching drive. Meaning I have no dvd drive key!

Crap.

.
Get someone who can fit the coolrunner to recover the key;)