SX AUTOLOADER

SX AUTOLOADER 1.20

No permission to download

badpix11

Full Member
Jul 13, 2018
29
3
It doesn't work if you have a big library on your HDD, the system starts to lag and the autoloader does only parse around 5~10 games per minute.
Hope there will be some improvements in future updates. SX Installer has a really fast parser or alternative a tool to create the cache files on pc if you have a lot of xcis.
 

GoodGuy

Noob Account
Oct 22, 2018
3
1
Gives u error when u connect the hardrive but when u take out the loader works fine they probably need to figure out what’s the issue that’s causing it to crash.
 

Wannabe

Noob Account
Oct 8, 2018
8
3
thank you very much Mcagle1030 , I had already asked for help 2 times here in the post and was simply ignored.
your method worked for me!
 

MOV AL_1

Noob Account
Nov 1, 2019
2
3
Porto
What an useful resource! Works fine for me (9.0.1/2.9.2).

This is great "as is" and if you manage to get rid of the "Insert game card" pop-up warning, you'll have produced a perfect 5 star add-on!
 
  • Like
Reactions: winecountrygame

cherup

Noob Account
Sep 23, 2018
8
3
Just discovered a bug using special characters. This will end in a crash and a reboot is needed.

used the title:

Pokémon

and ends with a crash. Once renamed it worked again:

Log looks like

[2019-11-05 20:22:39] Current File: usbhdd:/SXOS/Pok‚mon Lets Go, Pikachu! 1.0.0.xci
[2019-11-05 20:22:39] Reading XCI Start
[2019-11-05 20:22:39] header.cart_type: e0
[2019-11-05 20:22:39] FileSize: 4851431936
[2019-11-05 20:22:39] hfs0_header.num_files: 4
 

winecountrygame

Noob Account
Nov 1, 2018
5
1
Last edited:

pLd

Noob Account
Nov 5, 2019
5
13
Earth
Anyone getting the error 2011-0301 do the following:

-If you don't want the auto loader, just remove the sx os folder - Issue sorted.

-If you want the auto loader, delete the sx os folder, download the 1.1 version and extract to the sd card root so the first folder is named sx os, then download the auto loader 1.2 and extract to the root of the SD card, when asked if you want to replace say yes, this will keep what is needed and replace the rest, put SD card back on the switch and launch, this should get you up and running with no error and auto loader working, also allowing you to launch homebrew withouth crashing.
 
  • Like
Reactions: molcos

pLd

Noob Account
Nov 5, 2019
5
13
Earth
Nothing is happening for me, Firmware 9.0.1 and SXOS 2.9.2. I have followed every step but nothing is happening!
Inside the sxos folder creater a xci folder and put the xci games directly there, restart the switch and it will work, new update reads from there
 
  • Like
Reactions: Blubal

unko2k

Noob Account
Nov 2, 2019
1
1
The Moon
I have the same problems as others.
  • Sysnand 7.0.
  • Emunand 9.0.1
  • SX 2.9.2
  • Sx Autoloader 1.2
  • A lot games on xci HDD
  • HDD 2Tb Toshiba Usb 3.0 connected to the USB 3.0 port of the Dock (Format exfat)
  • Crash in Gallery when scanning the HDD
  • Delete Autoloader folder.. running without problems

maybe could be memory problems
 

Blubal

Noob Account
Mar 29, 2019
3
1
Oklahoma
Inside the sxos folder creater a xci folder and put the xci games directly there, restart the switch and it will work, new update reads from there
THIS ^^^^^

Hi all, I tried this out tonight and it seemed to do nothing at all -- nothing would auto-mount. Now it's working great! And is a neat feature for sure! So to reiterate -- The XCI games must be in sxos\xci

I had all my XCI games in switch\xci all this time. Using the PC, I just simply moved them to the "correct" folder and it fixed it! Hope this helps.
 
  • Like
Reactions: rscholtz

Palinkat

Full Member
Apr 5, 2018
34
8
Could someone confirm that filenames with extended characters are supported in 1.2?

Thanks a lot!!
 

dprdboy

Noob Account
Nov 2, 2019
2
1
Mexico
THIS ^^^^^

Hi all, I tried this out tonight and it seemed to do nothing at all -- nothing would auto-mount. Now it's working great! And is a neat feature for sure! So to reiterate -- The XCI games must be in sxos\xci

I had all my XCI games in switch\xci all this time. Using the PC, I just simply moved them to the "correct" folder and it fixed it! Hope this helps.
I have way too many games to move from switch/xci to sxos/xci. I had to go back to 1.10 in order to keep everything the same and it does work correctly.

I feel that the developers of this tool should include all directories that SX OS reads games from, not just from root and sxos directory. Don't know why they would do this change of directories when the previous versions worked fine.