SX AUTOLOADER

SX AUTOLOADER 1.20

No permission to download

Blubal

Noob Account
Mar 29, 2019
3
3
Oklahoma
I have way too many games to move from switch/xci to sxos/xci. I had to go back to 1.10 in order to keep everything the same and it does work correctly.

I feel that the developers of this tool should include all directories that SX OS reads games from, not just from root and sxos directory. Don't know why they would do this change of directories when the previous versions worked fine.
If you put the SD card into the PC, you can instantly move the files from folder to folder.... literally under one second. To be clear, do not COPY the files, then delete... actually MOVE them.
 

dprdboy

Noob Account
Nov 2, 2019
2
1
Mexico
If you put the SD card into the PC, you can instantly move the files from folder to folder.... literally under one second. To be clear, do not COPY the files, then delete... actually MOVE them.
But why do I have to do this when this WASN'T a requirement on version 1.10? It's like if SX OS just suddenly stopped scanning the /switch directory for games in the next version without the team stating anything and having to find out the hard way that it now scans games ONLY in the root directory. It just seems highly illogical to do such a move without reason.

If the developers had stated that the directory for the games HAD to be /sxos/xci because of one of their key features or bug fixes then sure, I'll move my games. But putting "just unpack the new version overwriting the previous files" and having to find out it doesn't work anymore because of they decided to change the scanned directory is just annoying to say the least.
 

Blubal

Noob Account
Mar 29, 2019
3
3
Oklahoma
Well, to put it simply, if you want 1.2 to work, then you have to do this -- that's the reason. Since it's trivial, who really cares if the files have to be moved? I moved mine and everything still works the same except now this utility works also. I agree it was annoying since I'd never used the utility before and to me it just appeared to not work at all (until I moved the XCI files). I'm just glad we are getting these updates and utilities for free. I'm grateful and as long as the requirements aren't bothersome I'll update my SD card to whatever format they want.
 

Ssjcagi4

Noob Account
Sep 18, 2019
6
1
Italy
In order to work properly with my USB HD, should I create a specific folder to put my xci games? I've read a lot about SD card but It's not clear which path it scans when an HD is involved.
 

Pupuko

Noob Account
May 1, 2019
2
1
Taiwan
Also having problems.
Emunand 9.0.1
Sx os 2.9.2
Autoloader 1.2
Using hdd
Autoloader only runs if I open switch undock and try any game to get the insert cartridge message. Then once docked, autoloader running. Once I choose a game, it will run perfectly. If I close the game, then try another xci, I get 2168-0002 error. If I restart the switch without removing from dock, I can't launch any game, even the ones installed. I always get 2168 error. Help, anyone?
 

pipostyle

Noob Account
Jan 3, 2019
7
3
france
When the switch was in standby mode and after that you try to select a game that was already selected, autoloader doesn't work.
I have to choose an another game without to enter in album then, the icon of game change, then i can reselect first game i wanted to play.

except this, all is working good . I'm in firmware 8.1
 

MaaAx

Noob Account
Nov 12, 2019
4
1
France
THIS ^^^^^

Hi all, I tried this out tonight and it seemed to do nothing at all -- nothing would auto-mount. Now it's working great! And is a neat feature for sure! So to reiterate -- The XCI games must be in sxos\xci

I had all my XCI games in switch\xci all this time. Using the PC, I just simply moved them to the "correct" folder and it fixed it! Hope this helps.
Doesn't work for me at all, the games don't appear on the Switch anymore. I get the message "please copy your files to the root of the SD card". If anyone has a clue, I'll be thankful :)
 
  • Like
Reactions: rscholtz

Yogesh

Full Member
Aug 25, 2018
43
6
I added auto loader in the root of the SD card but still get the error "Game card not found". Please give me the steps to take.
 

pLd

Noob Account
Nov 5, 2019
5
13
Earth
Doesn't work for me at all, the games don't appear on the Switch anymore. I get the message "please copy your files to the root of the SD card". If anyone has a clue, I'll be thankful
I added auto loader in the root of the SD card but still get the error "Game card not found". Please give me the steps to take.
Ok, so just to see if we can get all in the same page:

1 - Unzip the auto loader to the SD Card ( Once you open the SD Card there will be a folder there named sxos )
2 - Inside that sxos folder there will be other folders like titles and so on. YOU create inside sxos a folder named xci ( So now inside sxos you have 2 folders, one named title, and another named xci )
3 - You move all the xci games you want into the xci folder you created ( the xci file directly and not the file inside other folders, just the xci file itself )
4 - You go into folder titles, then into the folder 00FF0012656180FF, inside that you will have a folder named cach ( if you don't have a cach folder just put the sd card back into the switch and restart, it should now work ), inside the cach folder you have 2 folders named sd and hdd, delete them both, then put sd card back in the switch and restart, should now work.
5 - If it still doesn't work send screenshots of all the folders from the root of the SD card up to inside of cach folder.
6 - If it still doesn't work and you can't send screenshots as per above request, then may God Help you because I sure can't. :)
 

Noms

Senior Member
Oct 5, 2018
149
28
Aberdeen, Scotland
I am on sysnand 9.0.1 and 2.90.2 .

Only tried this with two xci games so far on external HDD - Legend of Zelda Link's Awakening works fine - A Hat in Time just hangs on INSERT GAME CART

EDIT

Seems after installing new titles you have to do a reboot to update the cach - all working fine now
 
Last edited:

WilliamWrath

Noob Account
Sep 2, 2018
9
3
Works fine with external HDD, although once the switch goes into sleep mode auto-loader stops working until the next restart. I pretty much fixed this by turning my settings to never but could this be fixed otherwise?
 

winecountrygame

Noob Account
Nov 1, 2018
5
1
Works like a charm for me the earlier version gave me a boot loop it wouldnt start the console the 1.2 works perfect! I have EmuNand 2.9.2 and the most recent firmware 9.1.0 I think. Still hoping they'll add the "Launch All" option so I dont need to do this one at a time would be soooo amazing!
 

Shingotink

Noob Account
Oct 7, 2018
2
1
For me at least it appears to work fine after a restart when using HDD, but any new games you add will not be added to the cache.
When/where exactly does autoloader scan for new XCI's? Can we please get a tab in the option menu to scan for xci so they get added to the cache?
 

MaaAx

Noob Account
Nov 12, 2019
4
1
France
Ok, so just to see if we can get all in the same page:

1 - Unzip the auto loader to the SD Card ( Once you open the SD Card there will be a folder there named sxos )
2 - Inside that sxos folder there will be other folders like titles and so on. YOU create inside sxos a folder named xci ( So now inside sxos you have 2 folders, one named title, and another named xci )
3 - You move all the xci games you want into the xci folder you created ( the xci file directly and not the file inside other folders, just the xci file itself )
4 - You go into folder titles, then into the folder 00FF0012656180FF, inside that you will have a folder named cach ( if you don't have a cach folder just put the sd card back into the switch and restart, it should now work ), inside the cach folder you have 2 folders named sd and hdd, delete them both, then put sd card back in the switch and restart, should now work.
5 - If it still doesn't work send screenshots of all the folders from the root of the SD card up to inside of cach folder.
6 - If it still doesn't work and you can't send screenshots as per above request, then may God Help you because I sure can't.
Hey! First of all, thanks so much for your kindness, you rock! I tried every step though and it still doesn't work. The cach folder is missing, no matter what I do. I'm doing this on Mac OS (with a way to show all the hidden files) and there's nothing here. I also get an error message each time I reboot the Switch: "SD card is missing". I clic on the pop-up message and then everything runs smoothly.
Here is the screenshot of my SD card:
https://pasteboard.co/IGuwZ6z.png
 

pLd

Noob Account
Nov 5, 2019
5
13
Earth
Hey! First of all, thanks so much for your kindness, you rock! I tried every step though and it still doesn't work. The cach folder is missing, no matter what I do. I'm doing this on Mac OS (with a way to show all the hidden files) and there's nothing here. I also get an error message each time I reboot the Switch: "SD card is missing". I clic on the pop-up message and then everything runs smoothly.
Here is the screenshot of my SD card:
https://pasteboard.co/IGuwZ6z.png
Thank you :)
Can you tell me ehat is the format type for your sd card?