SX installer 1.5 stuck on-loading with USB-HDD

Billy Hill

Full Member
Mar 9, 2019
36
8
Germany
I agree. USB install, dump, whatever dont works for me too.
I use latest OFW and CFW (autoRCM, no EmuNAND) and the lastet version of SX Installer too.

If i connect my Switch to the PC i just get this in the sxserver console:
(the part in german means: "Can not create file if file allready exists.")
16370

It repeats all the time and my Switch is frozen meanwhile. If i press the homebutton i get a full Switch crash
with error code: 2162-0002 . If i unplug the usb connection instead of pressing the home button the SxInstaller is
frozen but i can return to the homescreen with the homebutton.


If i connect a external hdd via usb it just happens nothing. i cant browser files through SX Installer and the
hdd dont appears somewhere.

No idea what to do, wireless it all works like a charm.


EDIT: I just noticed that my Switch is shown as "Nintendo Switch" in windows10. I wondered about that and checked the driver with zadig. It was turned to WinUSB so i replaced the driver with libusbk and restarted my system.
After restart the driver was still libusbk but a soon as i connect my switch and start SX Installer the driver sets back to WinUSB. Result is the connect/disconnect loop shown in the screenshot above...no idea what it is.

Edit2: I deinstalled the Nintendo Switch device in the device manager and restarted Win10. Connected the switch via usb and the device was shown as APX with missing drivers, as i expected. I started zadig 2.4 and it directly showed the APX device without any drivers. I installed libusbk again and the switch is shown as Nintendo Switch again in device manager. After starting SX Installer it shows an other error now :(

16371
 
Last edited:

Billy Hill

Full Member
Mar 9, 2019
36
8
Germany
I still found no solution for the problem. I tried a de- and reinstall of the USB driver several times, added the libusb.dll manualy into the server folder, installed libusb-win32-devel-filter-1.2.6.0 for the switch..nothing changed.

Interesting is that the same problem exist with Goldtree 0.5 + Fluffy and Goldtree + NS Usbloader. The only way installing via USB works is Goldtree + Goldleaf 0.5.
 

Billy Hill

Full Member
Mar 9, 2019
36
8
Germany
My problem with the error is solved after i formated my system partition and installed a clean windows 10.
Unforunatly im still not able to connect the switch with the lastest SX Installer via usb. It always shows me USB not connected.
Does anyone has an idea whats going wrong? Or is it actualy impossible to use SX Installer with a USB connection?
 

kalitbartman

Noob Account
Nov 14, 2018
7
1
DON'T USE THE NEW INSTALLER

1.52 (which i am using ) and some other versions aren't nsp's and you can use while a game is active

3.01 is an nsp and you can't use it with a game running it asks you to close it and you can't backup saves or even restore them (and i think you had to backup or restore your saves with the installer while the game is running

if you don't install nsp's you are less likey to get banned

if you install an nsp it's 100% ban