SX OS 3.0.3 beta not compatible with FW 10.0.1 ?

Maze

Full Member
Feb 6, 2019
25
3
Germany
So maybe someone will complain about this thread because "this topic is in discussion in every other thread" but guess what? If I asking my questions in threads I get ignored so I will try it on this way.

Troubleshooting:

Yesterday I updated my switch SXOS Firmware to 3.0.3 beta and the original Firmware from 9.4.0 to 10.0.1 with ChoiDujour and after this, some problems are running.
Long text short:

I can't boot in custom FW anymore. I tried so many things. I used different versions of SX OS. From 3.0.3 beta up to 2.9.2. Nothing is stable.
If I boot in CFW my Switch will become black and after few minutes it reboots automatically into normal FW.

If I change the CFW back to 3.0.3 beta, my switch won't boot anything. I can't even reach the RCM mode. If I press - after booting up, the red SX OS logo appears and then nothing. The switch is shutting down.

I don't know what to do. 2 days have passed since I tried to fix this problem but Iam done. I can't find a solution by myself and I really need your help.

What I did so far:

I tried to install atmosphere to boot in another custom FW to start ChoiDujour. I think here is the problem, the actual installed FW 10.0.1
I can't boot Atmosphere via Hekate because I get a fatal error. So back to the roots.

I tried to manipulate the original FW via ChoiDujour on my PC (there is a loooong tutorial to do that) but I can't read out the needed keys on the switch to work with it. There are many errors I can't solve so this is not an option.

I formatted my SD Card again and put only 2 files on it. The SXOS Firmware X.X.X and my licence. I start up the switch, blackscreen after switch logo and normal mode after a few seconds.

So far so good. I hope someone has a solution for this because Iam gonna crazy!

Edit:
Well I just remembered that as I installed the 10.0.1 with ChoiDujour , I clicked von 10.0.1 (install button) not exFat 10.0.1
I don't know if this is necessary?

Maybe I should reset the whole switch to the standard Firmware and erase anything?


So after many times I fixed it.
How did I do it?
Well first, I found a solution how to update my switch automatically with ban. My console updatet the version 10.0.4 and now all things are quite good.

Shut off your console. Make sure you have auto RCM disabled. Press Volume down and up and hold it. Switch the console on. Enter the Firmware menu and update your console automatically.

Problem solved.
 
Last edited: