SX Pro black screen

darkcain

Noob Account
Jul 12, 2019
4
1
canada
Hi all.
I'm new to this and I need your help.
I purchased the SX pro. I made a copy of my Nand and installed the Emunand. I activated my SX Pro and put the lisence.dat file on my micro SD.
I went back to SX Pro screen and clicked to start using custom FW. Then, blackscreen.

When I go back to the normal FW, I got a message saying that I needed to update the system to use the microSD. I did it, and now I'm in 8.1.0.
My microSD is in exFAT and I am using the beta 2.8 version.
On my microSD, I have boot.dat, changelog, info.json, licence.dat, SXDumper.nro, a switch file, a Emutendo file and a Nintendo file.

My switch is not patched, it's an old switch.

Can somebody help me?
 

Victorb9

Senior Member
Feb 8, 2019
122
18
UAE
Save your license on pc, format sd card and try to run CFW with only boot and license files on it.
 

darkcain

Noob Account
Jul 12, 2019
4
1
canada
I did a quick format. I saw that my 128 GB sd card is just 89 GB now. I guess the hidden partition when creating my emunand doesn't format. I tried to boot into custom FW and same thing, I see the Nintendo logo and then black screen.
So to tell, my emunand was created under firmware 8.0.1, and after that, I updated my system to 8.1.0
Does that create a problem?
 
Last edited:

darkcain

Noob Account
Jul 12, 2019
4
1
canada
Ok I did something new. On the SX screen, I clicked on the emunand enabled over the custom fw. After clicking on it, it changed to Emunand disabled and I clicked on start custom fw and I didn't get the black screen this time. I went on Album and I saw that my lisence is ACTIVATED. Is that good now? I mean, Am I doing good? Am I using the emunand?
 

imprezgc8

Majora's Mask
Staff member
Troll Eating Dogs
Top Poster Of Month
Nov 26, 2007
1,964
108
The Cloud
If emunand said disabled then you are not using emunand. Did you make a nand backup before dong any of this?

I would recommend SD files. Hidden partition is not really any safer and is more of a hassle to work with if things go wrong.
 

darkcain

Noob Account
Jul 12, 2019
4
1
canada
I did a nand backup. I managed to install my eshop game anyway. I guess it's just not installed on the emunand. I will try a new micro SD and create my emunand on it has you suggest.