SX Server help

Crazyjoe_uk

Noob Account
Sep 28, 2018
27
1
Hi all,

I've read on the downloads section that SX Server is an advanced user tool. I would like to have some files on my NAS, and launch them from there - is that possible with SX Server?
If it is possible, is there any guide on setting it up? I've read the "readme" included with SX Server, and it mentioned "set up a nut server" if your files don't appear - I'm clearly not advanced, as I thought it was a typo!

Thanks in advance
 

imprezgc8

Staff member
Troll Eating Dogs
Nov 26, 2007
1,204
108
The Cloud
If you want to install the backups then this will work for you. If you are trying to just mount XCI files, then I do not think so.

I jus set this up without much effort at all. I just mounted my network drive on my windows pc then double clicked the exe and in the top left corner put the path to my network share that I mounted. Then hit scan and all my games started showing up in the gui and I was able to connect with my Switch with no issue. There is no need for nut or anything. Launching the exe will take care of all the backend.
 
  • Like
Reactions: Crazyjoe_uk

Dabman

Noob Account
Feb 18, 2019
20
3
Germany
Hey,
let's bring that thread back to live ;-D
I've got SX Installer 1.5 on my Switch and want to use SX Server v 1.1 to install .NSPs via Network - is this possible?
Searched this forum but can't find any tutorial for SX Server - maybe i'm blind, maybe there is really no tutorial out there. o_O

Hope someone can help me.

Greets

Dabman 😎
 

imprezgc8

Staff member
Troll Eating Dogs
Nov 26, 2007
1,204
108
The Cloud
There is no a guide yet. Basically just download the exe, open it and then in the top left there is a little box that has the path to your backups. Just change that to point to what every folder you have your backups saved and then press the refresh button.

Just threw this together. GUIDE: SX Server. Hope that helps.
 
Last edited:
  • Like
Reactions: Dabman

Dabman

Noob Account
Feb 18, 2019
20
3
Germany
Thanks a lot.
I started the sxserver.exe but couldn’t find where to add the path and so on. Will try it later, i‘m searching for a more comfortable way to install/restore backups/homebrews.
It has more style then just eject mSD, insert to pc, copy files, insert mSD back to NSwitch and so on....

Greets!:mario:
 

imprezgc8

Staff member
Troll Eating Dogs
Nov 26, 2007
1,204
108
The Cloud
Thanks a lot.
I started the sxserver.exe but couldn’t find where to add the path and so on. Will try it later, i‘m searching for a more comfortable way to install/restore backups/homebrews.
It has more style then just eject mSD, insert to pc, copy files, insert mSD back to NSwitch and so on....

Greets!:mario:
It works very well. Once you get the GUI window after the CMD window, there should be a little white box in the top left. It will have a path already there. You just click in the box, delete whats there and past what your path is. I updated the screenshots with the help of another user to highlight some of the spots in the screenshots.
 
  • Like
Reactions: Dabman

Dabman

Noob Account
Feb 18, 2019
20
3
Germany
Hi,
me again :)
I've had a few tries to get SX Server working but i can't connect to it within SX Installer v1.5.
My settings in SX Installer are:
Protocol: nut
Host: [IP from top of the SX Server GUI]
Port: 9000
username & pssword: guest

SX Installer is still not able to connect or find my sx server running on my windows pc.
Can someone help me? Thanx a lot!

Edit: On Switch FTP enabled i can connect to switch via FileZilla without problems.
 

imprezgc8

Staff member
Troll Eating Dogs
Nov 26, 2007
1,204
108
The Cloud
This is probably going to sound dumb and it could just be my Switch, but sometimes when I launch the installer my Switch looses my network connection and I have to exit, wait for it to come back and then launch the installer again. Not sure if it's my switch or something buggy with the installer. Worth a try.

Make sure you have a connection, launch the Installer and make sure at the top you have the network icon. Should be wifi bars. Nots sure if it changes if you are hardwired.
 
  • Like
Reactions: Dabman

Dabman

Noob Account
Feb 18, 2019
20
3
Germany
Now i've tried everything but i can't get SX Server work...
I've tried every profile and opened every type of port 9000 on my router - nothing works. SX Installer is only able to see whats on my SD-Card...
Switch is running with WiFi ON and SX OS Stealth Mode on <- could this be a problem? (i don't think TX would block their own services via Stealth Mode)

EDIT: i figured out inadvertently as i tried to Set up another Server-program.
I‘ve had to check both boxes on both sxserver.exe through windows defender firewall!

4A12EFFB-60A5-4806-90B0-D32F03CFB450.jpeg

When i started sx Server for the First Time Windows automatically asked me to Open the program in the Firewall BUT on every sxserver.exe was only one box ticked.
Now SX Server works well with sx Installer :)
 
Last edited:
  • Like
Reactions: Game_Over

Game_Over

Staff member
Top TX Brass
Dec 2, 2010
5,022
138
127.0.0.1
Now i've tried everything but i can't get SX Server work...
I've tried every profile and opened every type of port 9000 on my router - nothing works. SX Installer is only able to see whats on my SD-Card...
Switch is running with WiFi ON and SX OS Stealth Mode on <- could this be a problem? (i don't think TX would block their own services via Stealth Mode)

EDIT: i figured out inadvertently as i tried to Set up another Server-program.
I‘ve had to check both boxes on both sxserver.exe through windows defender firewall!

View attachment 16270

When i started sx Server for the First Time Windows automatically asked me to Open the program in the Firewall BUT on every sxserver.exe was only one box ticked.
Now SX Server works well with sx Installer :)

networking 101 :p

Glad you got it working. Thanks for sharing in case someone else runs into this.
 
  • Haha
Reactions: Dabman

imprezgc8

Staff member
Troll Eating Dogs
Nov 26, 2007
1,204
108
The Cloud
Glad you got it sorted out!
 
  • Like
Reactions: Dabman

Dabman

Noob Account
Feb 18, 2019
20
3
Germany
Yeah, one little tick in the Box and a whole System can‘t run 😅
I think it was Bowser :eek::mario:
 
  • Like
Reactions: imprezgc8

Support Our Sponsors