sxinstaller 3.02 cannot be launched anymore

mrbarnie

Noob Account
Nov 25, 2018
3
1
Hello guys,

this version was already running but suddently I could not launch it anymore.
The main menu on switch says "software needs to be downloaded" and the cloud symbol above the sxinstaller icon appears.
I removed the corresponding folder on the sdcard and recopied it but it did not solve the problem.

I am running 9.1.0. and 2.9.3

Does someone has any idea?

I hope when sxinstaller works again I am able to restore my saved games settings...

Thanks
MrBarnie
 
Last edited:

FishAndChips

Noob Account
Jan 10, 2020
4
1
Cyberspace
I had the same problem as the original poster after I reformatted my SD card and started from scratch.

Firmware: 9.1.0
All I had on the SD card was SX-OS 2.9.3 beta, SX Installer 3.0.2, Tinfoil 7.01 and my reinstalled games.

Launching SX Installer resulted in the following error message:
"The software data is not downloaded. It will be downloaded now." -> DOWNLOAD -> "Error Code 2137-8035"

Tinfoil launched fine.

The solution:
Delete the sx folder
Recopy across SX Installer 3.0.0 (can be obtained from the SX Installer 3.0.2 official link by editing the URL)
Run SX Installer 3.0.0
Exit after it has loaded up fully
Copy SX Installer 3.0.2 files over the 3.0.0 files

Now SX Installer 3.0.2 launches properly.
 

ChokingVictim87

Noob Account
Dec 16, 2019
8
1
Australia
I had the same problem as the original poster after I reformatted my SD card and started from scratch.

Firmware: 9.1.0
All I had on the SD card was SX-OS 2.9.3 beta, SX Installer 3.0.2, Tinfoil 7.01 and my reinstalled games.

Launching SX Installer resulted in the following error message:
"The software data is not downloaded. It will be downloaded now." -> DOWNLOAD -> "Error Code 2137-8035"

Tinfoil launched fine.

The solution:
Delete the sx folder
Recopy across SX Installer 3.0.0 (can be obtained from the SX Installer 3.0.2 official link by editing the URL)
Run SX Installer 3.0.0
Exit after it has loaded up fully
Copy SX Installer 3.0.2 files over the 3.0.0 files

Now SX Installer 3.0.2 launches properly.
I followed your steps exactly and I got : FATAL ERROR INTERCEPTED. ERRORO REASON-.NRO FILE MISSING FROM DECLARED PATH.PLEASE FIX PATH AND TRY AGAIN
 

ChokingVictim87

Noob Account
Dec 16, 2019
8
1
Australia
Sorry to hear it didn't work for you.

In my switch/sx directory, I have
sx.nro, and
058BFCC801A80000.nsp

Do you have both of these files there?
Where are you putting these on the SD? For some reason, homebrew apps only ever show when I but the .nro on the root of the SD card, never elsewhere.
 

ChokingVictim87

Noob Account
Dec 16, 2019
8
1
Australia
sx.nro and the .nsp are in the switch/sx directory.

My root directory has only
boot.dat, and
license.dat
Wow-mine is full of stuff! Think its maybe because Im using a Mac?

So heres what I have just tried:

Putting the latest .nro and .nsp installer files in an sx folder within the switch folder that is on the root = Not showing on Homebrew tab or anything

Putting the latest .nro and .nsp installer files on my root=Shows up on installer and Homebrew. When clicked on in Homebrew I get the same message I previously stated in an earlier post. When installed and then clicked on in the games library I get the same message as above

I then tried version 3.0.1 and put just the .nro and .nsp on my sd root. They both showed and loaded up fine! Am I right in thinking newer updates/DLC/titles wont show up as installable on this though due to it being an older installer?
 
Last edited:

optantic

VIP Member
May 2, 2010
617
48
Wow-mine is full of stuff! Think its maybe because Im using a Mac?

So heres what I have just tried:

Putting the latest .nro and .nsp installer files in an sx folder within the switch folder that is on the root = Not showing on Homebrew tab or anything

Putting the latest .nro and .nsp installer files on my root=Shows up on installer and Homebrew. When clicked on in Homebrew I get the same message I previously stated in an earlier post. When installed and then clicked on in the games library I get the same message as above

I then tried version 3.0.1 and put just the .nro and .nsp on my sd root. They both showed and loaded up fine! Am I right in thinking newer updates/DLC/titles wont show up as installable on this though due to it being an older installer?
you don't put any .nro file on the root, download the zip file then extract the switch folder to the root
 

FishAndChips

Noob Account
Jan 10, 2020
4
1
Cyberspace
Wow-mine is full of stuff! Think its maybe because Im using a Mac?
There's your problem (unfortunately).

See

Macs = homebrew doesn't appear on the Switch even though it's been copied to the SD card in the correct place.