Touch screen doesn't work most of the time when booting SX OS?

ash47

Noob Account
Nov 5, 2018
4
0
Hi all,

SX OS was originally working fine, then, all of a sudden the touch screen no longer works within SX OS during most boots.

I can boot into the standard switch OS and the touch screen works fine.

If I spend 30+ minutes booting into SX OS, hard restarting it, and booting it, eventually it will boot with a working touch screen.

There seems to be some really weird condition or something that is causing it from starting.

I am happy to run any custom versions of SX OS to debug this issue if required. Alternately, can you add an option to have a config file that will just boot directly into custom firmware, that way, I don't need to worry about the touch screen?

This didn't happen after a certain patch, it was working one day, and then just broke another day, I've tried tons of different versions of SX OS, I've tried stable and beta, no dice, it's random when it works :/

Happy to answer any and all questions.

Edit: Possible way to reproduce this is to have your fingers on the touchscreen while it boots


edit2: I SOLVED IT! Put the RCM into the controller slide thing, and plug the dongle into the USB C port, ensure the switch is off. You need to look at the dongle itself, hold the power up button, press the power on button ONCE, watch the dongle itself, wait for it to flash green ONCE, then let everything go, it will start to load SX OS, then it will boot directly into switch OS -- bypassing the screen that freezes :D

Means I can't use some of the functions, but meh, I don't care right now, I can play games again :D
 
Last edited: