Trinity Slim Demon install, retail not turning off CR Rev C

xxbeefydjxx

Noob Account
Apr 16, 2019
6
1
Xbox
Hi,

I recently managed to lay my hands on a legit Demon Slim chip with Corona QSB, I successfully installed the chip and can confirm i can read, and write to both nands and the coolrunner no problem.

The Demon side with RGH2 Nand flashed works perfectly, it boots within 2 cycles and often instaboots. Nice!
However, on the Stock Nand, with a stock nand flashed the console just sits there with a green power light. No attempt to boot. The coolrunner flashes green for a split second, then sits idle.
(I used the original nand rip I took of the console, it's not been updated since so no issues with anything there)

I have so far ensured that the Demon is set to XB, not PC, I have also triple checked and cleaned all my solder joints.
I have checked the ribbon cables, Used the alternative EN point on the Demon, Ensured I flashed the correct Timing files with Demon enabled, tried multiple Demon timing files just in case.
If I turn the Coolrunner to PRG, I can boot retail no issue. So it's definitely an issue with EN on these boards...

I think the issue here lies in the fact that the Coolrunners are clones, This is due to the fact I can't seem to find ANY Genuine stock of any TX chips now a days :(
The clones do not have EN on the board, so the EN point is soldered the same way it is on OG Coolrunners and Rev B.

If there any other way to set up the EN points? I was told that I could remove the power from the chip, and solder EN to the 3.3v on the CoolRunner?

Failing this does anyone know some reputable sources where I can get a CR3 or a Rev C? At whits end and just want to finish this console off. (xK3y + Demon + Coolrunner, 2TB HDD Trinity GOW3 Console)

Any guidance would be much appreciated. I understand the clones are not supported here, but don't want to fix these, just want to know if there are any alt points or ways of hooking up the EN points to a Rev C...

Thanks.
 

xxbeefydjxx

Noob Account
Apr 16, 2019
6
1
Xbox
from the pics looks like some of the points are not making any contact. did you try flashing original nand to demon to see if console boots up? dont forget to remove power to CR.
The board is raised slightly, but I can confirm that these are making a strong connection and if I put Stock nand on the Demon and turn the CR to PRG (off) it boots just fine.

I'm pretty sure these damn clone FPGAs do not have any support for the EN pin out, which is weird... I have ordered a Genuine CR4 XL from Modchip Central and am awaiting that order to be processed.

I will be sure to report back on if replacing with a newer chip works out. (If it doesn't then I'm throwing it off the roof lmao)
 

xxbeefydjxx

Noob Account
Apr 16, 2019
6
1
Xbox
so u flashed retail nand to both the onboard and demon. and ur able to boot console?
Yes. Both hands boot stock with chip turned off. The chip just won't turn off with en definitely attached and EN Enabled timing definitely flashed.

It's so strange.