ANSWERED X360USB PRO V2 Stuck in bootloader mode

Redneck_Moddz_91

Noob Account
Apr 21, 2012
5
0
I have a x360usb pro v2 and its stuck in bootloader mode its updated to the newest firmware was working fine and pluged it in one day and would show up on my pc so i opened the x360 usb pro firmware updater and its stuck in bootloader mode i reflashed it with the v20.1 firmware and it goes out bootloader mode i switch the update switch off and it gets put right back in bootloader mode if anyone can help that would be great thanks. Im Also running windows 7 ultimate 32 bit system and i flash all dvd drives on phat 360s
 
Last edited:

Redneck_Moddz_91

Noob Account
Apr 21, 2012
5
0
ok so i got it out of bootloader mode now i open jungle flasher and its showing up but with no com ports. should i uninstall the drivers and reinstall maybe that will work
 

BL4K3Y

VIP Member
Jul 7, 2010
12,863
118
Colne, Lancashire (UK)
You need to install the CK3i drivers before it's COM port will show up in JungeFlasher.

You need 12V connected to your X360USB Pro V2 or your computer won't detect the CK3i.
 
Last edited:

Redneck_Moddz_91

Noob Account
Apr 21, 2012
5
0
ive installed all drivers and updated the usbpro work for a min soon as i restart the computer it doesnt show up any more this usb pro v2 was a waste of money its been giving me probles right out the box brand new it must be faulty or something im just going to get my old cki out and et a pci express sata card
 
  • Like
Reactions: troubletall

Redneck_Moddz_91

Noob Account
Apr 21, 2012
5
0
ok so i got the usb pro working its wierd thow it wont work with the update switch off but works perfectly fine withe the update switch on so yeah its working now but the switch is backwards thanks for the help and sorry for my frustration :). and my com ports still dont sho up but it powers the drive fine and still unlocks the drives fine so im happy but this is weird lol
 

Redneck_Moddz_91

Noob Account
Apr 21, 2012
5
0
ok so idk why but i got it working right no com ports were showing up so i decided to hook up my old ck3 i up with the usb pro to power it up and with the to its working but switch is still backwards but its ok it shows the com ports now so im backing up a game with my beng with v0800 firmware problem solved idk how to delete this thread but if a moderate can delete it go ahaed thanks for the help BL4K3Y
 

zozz99

Noob Account
Jun 3, 2016
4
0
I have a x360 usb pro 2. and it was a pig to set up got it working but now when you turn it off stays on had it week the most rubbish I have ever owned no back at all wish I given the money to the poor really disappointed only wanted to change my drive if any body can help