GENERAL XDrive Help

caver99

VIP Member
Dec 16, 2003
179
23
Ellesmere Port
Right i have an xdrive i have put a spare samsung m78 drive in, now this is were the problems start.
drive is reconized in xbc and when media is inserted its reconized but when you go to read all goes fine till it does speed test to start reading and it failes on sector read.
i have checked the 12v on the little circut board and thats just fine but the ground is missing all over the place like fan, front led if i bridge to these i can get the drive to read.
what i am after is if one of team xecuter could help in finding where/what is broken i.e. if a component has blown or there is a track broke.
now the fan and led grounds do not have continuity to each other or psu or dvd socket.

Can someone please help.
before anyone says send this back it was bought second hand so i would prefer to fix this or if i can but a new circut board from TX.

Thanks


Graham
 

xboxhack11

VIP Member
Nov 6, 2011
197
0
I am thinking the OP probably does not even have that flashed to his drive. Anyone up for a game of space invaders?
 

xboxhack11

VIP Member
Nov 6, 2011
197
0
Although it appears you already know the answer to your problem, but I think you will need to be more specific about what the problem is if you want help.

By your post it appears you are trying to rip a game with XBC from your computer and it is failing at the beginning.

This could be a driver issue or a firmware issue, but you go on to talk about grounding issues.
 

caver99

VIP Member
Dec 16, 2003
179
23
Ellesmere Port
it only fails if I connect the DVD lead through the xdrive, if I connect the DVD from my ck3i to DVD directly the the game will rip no problem at all
when the xdrive is connected and powered the fan and led do not work after checking with meter around the xdrive circuit board I get 12v and 5v bout the ground is ok between the DVD connector and the 12v external power connector but to the led and fan circuits is no ground I am suspecting either a component has gone or one of the vias is not connected through the layers of circuit board
 

caver99

VIP Member
Dec 16, 2003
179
23
Ellesmere Port
ok so i have found that is i install all the components in the xbox and plug the 3.5mm plug from the xbox to the xdrive and connect my x360usb and ck3i i can get the xdrive to rip every time so to ask TX this the 3.5mm socket on the back of the xdrive what is this doing insidew the xdrive?